summaryrefslogtreecommitdiff
path: root/guix/build-system/perl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-30 22:56:38 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-30 22:57:03 +0100
commita18eda2747fa2eb962e3288066d2b1a679589ed3 (patch)
tree3622bccc9d73d6f09eb1a89be841d8faacbc32d5 /guix/build-system/perl.scm
parent5cfdb4bcac145abb4f6ce29aaf8fd46504e9e0a9 (diff)
downloadguix-patches-a18eda2747fa2eb962e3288066d2b1a679589ed3.tar
guix-patches-a18eda2747fa2eb962e3288066d2b1a679589ed3.tar.gz
packages: Add `native-search-paths' field and honor it.
* guix/packages.scm (<search-path-specification>): New record type. (search-path-specification->sexp): New procedure. (<package>)[native-search-paths]: New field. (package-derivation): Accumulate the search paths, and pass them as #:search-paths toe BUILDER. * guix/build-system/gnu.scm (gnu-build): Add #:search-paths. Compute `implicit-search-paths'. Pass #:search-paths in BUILDER. * guix/build-system/perl.scm (perl-build): Add #:search-paths, pass it to BUILDER with the search paths of PERL. * guix/build-system/cmake.scm (cmake-build): Add #:search-paths, pass it to BUILDER. * guix/build-system/trivial.scm (trivial-build): Add #:search-paths, ignore it. * guix/build/gnu-build-system.scm (set-paths): Add #:search-paths. Remove explicit settings of CPATH, LIBRARY_PATH, and PKG_CONFIG_PATH. Instead, walk SEARCH-PATHS and call `set-path-environment-variable' for them. * guix/build/perl-build-system.scm (perl-build): Remove PERL5LIB setting. * tests/packages.scm ("search paths"): New test. * gnu/packages/bootstrap.scm (%bootstrap-guile)[raw]: Add #:search-paths. (%bootstrap-gcc): Add `native-search-paths' field. * gnu/packages/perl.scm (perl): Likewise. * gnu/packages/pkg-config.scm (pkg-config): Likewise. * gnu/packages/glib.scm (intltool): Remove `arguments'. * gnu/packages/avahi.scm (avahi): Remove #:phases.
Diffstat (limited to 'guix/build-system/perl.scm')
-rw-r--r--guix/build-system/perl.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/guix/build-system/perl.scm b/guix/build-system/perl.scm
index 537c29e799..c97698e225 100644
--- a/guix/build-system/perl.scm
+++ b/guix/build-system/perl.scm
@@ -38,6 +38,7 @@
(define* (perl-build store name source inputs
#:key
(perl (@ (gnu packages perl) perl))
+ (search-paths '())
(tests? #t)
(make-maker-flags ''())
(phases '(@ (guix build perl-build-system)
@@ -53,6 +54,9 @@
(guix build utils))))
"Build SOURCE using PERL, and with INPUTS. This assumes that SOURCE
provides a `Makefile.PL' file as its build system."
+ (define perl-search-paths
+ (package-native-search-paths perl))
+
(define builder
`(begin
(use-modules ,@modules)
@@ -60,6 +64,9 @@ provides a `Makefile.PL' file as its build system."
#:source ,(if (and source (derivation-path? source))
(derivation-path->output-path source)
source)
+ #:search-paths ',(map search-path-specification->sexp
+ (append perl-search-paths
+ search-paths))
#:make-maker-flags ,make-maker-flags
#:system ,system
#:test-target "test"