summaryrefslogtreecommitdiff
path: root/guix/build-system/perl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-04 00:41:46 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-04 00:48:00 +0100
commit08fd1ebefdf7a61ede3de490dc466bc41ef1ba97 (patch)
tree438de092cd40f088d81f076adcaf05bad14f6f98 /guix/build-system/perl.scm
parent6af3101999b4cec58d10f28c257afc63ebc483a4 (diff)
downloadguix-patches-08fd1ebefdf7a61ede3de490dc466bc41ef1ba97.tar
guix-patches-08fd1ebefdf7a61ede3de490dc466bc41ef1ba97.tar.gz
Add (guix build-system perl).
* guix/build-system/perl.scm, guix/build/perl-build-system.scm: New files. * Makefile.am (MODULES): Add them. * guix/build-system/gnu.scm (standard-inputs): Make public.
Diffstat (limited to 'guix/build-system/perl.scm')
-rw-r--r--guix/build-system/perl.scm103
1 files changed, 103 insertions, 0 deletions
diff --git a/guix/build-system/perl.scm b/guix/build-system/perl.scm
new file mode 100644
index 0000000000..537c29e799
--- /dev/null
+++ b/guix/build-system/perl.scm
@@ -0,0 +1,103 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build-system perl)
+ #:use-module (guix store)
+ #:use-module (guix utils)
+ #:use-module (guix derivations)
+ #:use-module (guix build-system)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix packages)
+ #:use-module (ice-9 match)
+ #:export (perl-build
+ perl-build-system))
+
+;; Commentary:
+;;
+;; Standard build procedure for Perl packages using the "makefile
+;; maker"---i.e., "perl Makefile.PL". This is implemented as an extension of
+;; `gnu-build-system'.
+;;
+;; Code:
+
+(define* (perl-build store name source inputs
+ #:key
+ (perl (@ (gnu packages perl) perl))
+ (tests? #t)
+ (make-maker-flags ''())
+ (phases '(@ (guix build perl-build-system)
+ %standard-phases))
+ (outputs '("out"))
+ (system (%current-system))
+ (guile #f)
+ (imported-modules '((guix build perl-build-system)
+ (guix build gnu-build-system)
+ (guix build utils)))
+ (modules '((guix build perl-build-system)
+ (guix build gnu-build-system)
+ (guix build utils))))
+ "Build SOURCE using PERL, and with INPUTS. This assumes that SOURCE
+provides a `Makefile.PL' file as its build system."
+ (define builder
+ `(begin
+ (use-modules ,@modules)
+ (perl-build #:name ,name
+ #:source ,(if (and source (derivation-path? source))
+ (derivation-path->output-path source)
+ source)
+ #:make-maker-flags ,make-maker-flags
+ #:system ,system
+ #:test-target "test"
+ #:tests? ,tests?
+ #:outputs %outputs
+ #:inputs %build-inputs)))
+
+ (define guile-for-build
+ (match guile
+ ((? package?)
+ (package-derivation store guile system))
+ ((and (? string?) (? derivation-path?))
+ guile)
+ (#f ; the default
+ (let* ((distro (resolve-interface '(gnu packages base)))
+ (guile (module-ref distro 'guile-final)))
+ (package-derivation store guile system)))))
+
+ (let ((perl (package-derivation store perl system)))
+ (build-expression->derivation store name system
+ builder
+ `(,@(if source
+ `(("source" ,source))
+ '())
+ ("perl" ,perl)
+ ,@inputs
+
+ ;; Keep the standard inputs of
+ ;; `gnu-build-system'.
+ ,@(standard-inputs system))
+
+ #:modules imported-modules
+ #:outputs outputs
+ #:guile-for-build guile-for-build)))
+
+(define perl-build-system
+ (build-system (name 'perl)
+ (description "The standard Perl build system")
+ (build perl-build)))
+
+;;; perl.scm ends here