summaryrefslogtreecommitdiff
path: root/guix/build-system/gnu.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-03 20:12:59 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-04 00:10:03 +0200
commitafd3d9316ce3c48cd7f7dbae64be0f8bcb756ba6 (patch)
treee53fe41f65e71aae9257aa37d8e1fd9ad6706439 /guix/build-system/gnu.scm
parent8a55e217ad3a6af96f9e05eb676616224fde509f (diff)
downloadguix-patches-afd3d9316ce3c48cd7f7dbae64be0f8bcb756ba6.tar
guix-patches-afd3d9316ce3c48cd7f7dbae64be0f8bcb756ba6.tar.gz
Use "normalized codesets" everywhere.
In other words, change "xx_YY.UTF-8" to "xx_YY.utf8". * guix/profiles.scm (ca-certificate-bundle): Use "en_US.utf8" instead of "en_US.UTF-8". * guix/packages.scm (patch-and-repack): Likewise. * guix/build/gnu-build-system.scm (install-locale): Likewise. * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Likewise. * gnu/packages/python.scm (python-ipython): Likewise. * gnu/packages/gawk.scm (gawk): Likewise. * build-aux/hydra/demo-os.scm: Likewise. * gnu/packages/guile.scm (guile-ncurses)[arguments]: Remove 'change-locale' phase.
Diffstat (limited to 'guix/build-system/gnu.scm')
-rw-r--r--guix/build-system/gnu.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index 1f302447c2..3be83468eb 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -287,7 +287,7 @@ standard packages used as implicit inputs of the GNU build system."
"bin" "sbin"))
(validate-runpath? #t)
(phases '%standard-phases)
- (locale "en_US.UTF-8")
+ (locale "en_US.utf8")
(system (%current-system))
(build (nix-system->gnu-triplet system))
(imported-modules %gnu-build-system-modules)
@@ -422,7 +422,7 @@ is one of `host' or `target'."
"bin" "sbin"))
(validate-runpath? #t)
(phases '%standard-phases)
- (locale "en_US.UTF-8")
+ (locale "en_US.utf8")
(system (%current-system))
(build (nix-system->gnu-triplet system))
(imported-modules %gnu-build-system-modules)