summaryrefslogtreecommitdiff
path: root/guix/build-system/cmake.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-05 16:32:25 +0200
committerLudovic Courtès <ludo@gnu.org>2014-10-05 21:58:42 +0200
commitd3d337d2d8f7152cb9ff3724f1cf240ce5ea5be2 (patch)
tree4b1c5c20515e88fdecf1626673d1f9864942ab1f /guix/build-system/cmake.scm
parentb4469d8c12905f07a6825654bc3313beb0563cad (diff)
downloadguix-patches-d3d337d2d8f7152cb9ff3724f1cf240ce5ea5be2.tar
guix-patches-d3d337d2d8f7152cb9ff3724f1cf240ce5ea5be2.tar.gz
build-system: Bags record their system and target.
* guix/build-system.scm (<bag>)[system, target]: New fields. (make-bag): Add #:system parameter and pass it to LOWER. * gnu/packages/bootstrap.scm (make-raw-bag): Initialize 'system' field. * guix/build-system/cmake.scm (lower): Likewise. * guix/build-system/perl.scm (lower): Likewise. * guix/build-system/python.scm (lower): Likewise. * guix/build-system/ruby.scm (lower): Likewise. * guix/build-system/trivial.scm (lower): Likewise. * guix/build-system/gnu.scm (lower): Initialize 'system' and 'target' fields. * guix/packages.scm (bag->derivation, bag->cross-derivation): New procedures. (package-derivation, package-cross-derivation): Use 'bag->derivation'. * tests/packages.scm ("search paths"): Initialize 'system' and 'target' fields. ("package->bag", "package->bag, cross-compilation", "bag->derivation", "bag->derivation, cross-compilation"): New tests.
Diffstat (limited to 'guix/build-system/cmake.scm')
-rw-r--r--guix/build-system/cmake.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index 0e750c0e11..85acc2d0b3 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -43,7 +43,7 @@
(module-ref module 'cmake)))
(define* (lower name
- #:key source inputs native-inputs outputs target
+ #:key source inputs native-inputs outputs system target
(cmake (default-cmake))
#:allow-other-keys
#:rest arguments)
@@ -54,6 +54,7 @@
(and (not target) ;XXX: no cross-compilation
(bag
(name name)
+ (system system)
(host-inputs `(,@(if source
`(("source" ,source))
'())