summaryrefslogtreecommitdiff
path: root/guix/build-system/cmake.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-04 22:59:38 +0200
committerLudovic Courtès <ludo@gnu.org>2014-10-04 22:59:38 +0200
commit9849cfc12cada96759af779a105f6999d6cc04c8 (patch)
tree64c1b60ffebda7015affa3d6119358622d966116 /guix/build-system/cmake.scm
parent3dcd78109c62b6837c4397ea60087d13e5f8814d (diff)
downloadguix-patches-9849cfc12cada96759af779a105f6999d6cc04c8.tar
guix-patches-9849cfc12cada96759af779a105f6999d6cc04c8.tar.gz
build-system/cmake: Add #:build-type parameter, default to "RelWithDebInfo".
* guix/build-system/cmake.scm (cmake-build): Add #:build-type. Pass it in BUILDER. * guix/build/cmake-build-system.scm (configure): Add #:build-type parameter and honor it. * doc/guix.texi (Build Systems): Document #:configure-flags and #:build-type for CMake.
Diffstat (limited to 'guix/build-system/cmake.scm')
-rw-r--r--guix/build-system/cmake.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index 0fc7b62c1b..5673ad5aeb 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -49,6 +49,7 @@
(make-flags ''())
(cmake (default-cmake))
(out-of-source? #t)
+ (build-type "RelWithDebInfo")
(tests? #t)
(test-target "test")
(parallel-build? #t) (parallel-tests? #f)
@@ -83,6 +84,7 @@ provides a 'CMakeLists.txt' file as its build system."
#:configure-flags ,configure-flags
#:make-flags ,make-flags
#:out-of-source? ,out-of-source?
+ #:build-type ,build-type
#:tests? ,tests?
#:test-target ,test-target
#:parallel-build? ,parallel-build?