summaryrefslogtreecommitdiff
path: root/guix/build-system/cmake.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-10 23:15:57 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-10 23:15:57 +0200
commit7e2b10a53f00d6d2bb2b3c799deeda7cd201338a (patch)
treef0ac752ebef6c6cc2a839532a313d94afe36e3ac /guix/build-system/cmake.scm
parentde80b5045b8467c34a7d53a6b62628202595f089 (diff)
downloadguix-patches-7e2b10a53f00d6d2bb2b3c799deeda7cd201338a.tar
guix-patches-7e2b10a53f00d6d2bb2b3c799deeda7cd201338a.tar.gz
build-system/{gnu,cmake}: Remove #:patches and #:patch-flags parameters.
* guix/build/gnu-build-system.scm (patch): Remove. (%standard-phases): Remove 'patch'. * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Remove #:patches and #:patch-flags parameters. * guix/build-system/cmake.scm (cmake-build): Likewise. * guix/build-system/python.scm (package-with-explicit-python): Update comment.
Diffstat (limited to 'guix/build-system/cmake.scm')
-rw-r--r--guix/build-system/cmake.scm3
1 files changed, 0 insertions, 3 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index 9461b19a2e..5f5c243572 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -47,7 +47,6 @@
(outputs '("out")) (configure-flags ''())
(search-paths '())
(make-flags ''())
- (patches ''()) (patch-flags ''("--batch" "-p1"))
(cmake (default-cmake))
(out-of-source? #f)
(tests? #t)
@@ -81,8 +80,6 @@ provides a 'CMakeLists.txt' file as its build system."
#:search-paths ',(map search-path-specification->sexp
(append search-paths
(standard-search-paths)))
- #:patches ,patches
- #:patch-flags ,patch-flags
#:phases ,phases
#:configure-flags ,configure-flags
#:make-flags ,make-flags