summaryrefslogtreecommitdiff
path: root/guix/build-system/cmake.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-03-20 21:38:19 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-03-20 21:38:19 -0400
commit2f33a7321e5e37d37f57c229c8079cb4ffd10834 (patch)
tree6f733a01608d00bb70c2a15a2c290f0adfe2c7e6 /guix/build-system/cmake.scm
parente16cf2666ffae3d5c008f092630d1b65eb8b1598 (diff)
downloadguix-patches-2f33a7321e5e37d37f57c229c8079cb4ffd10834.tar
guix-patches-2f33a7321e5e37d37f57c229c8079cb4ffd10834.tar.gz
cmake: Generate documentation.
To prevent complicating the dependencies of a core tool, a new variant, CMAKE-MINIMAL is introduced and the CMake build system is configured to use it by default. The regular CMAKE package gains a manpage, info manual as well as HTML documentation. Fixes issue #33497 (https://bugs.gnu.org/33497). * gnu/packages/cmake.scm (gnu): Use modules (gnu packages python-xyz), (gnu packages texinfo) and (srfi srfi-1). (cmake-minimal): Rename the original cmake variable to this. [phases]{configure}: Extract the configure script arguments to... [configure-flags]: here. [properties]: Set the HIDDEN? property to #t. (cmake): New variable, which inherits from CMAKE-MINIMAL. [phases]{move-html-doc}: Add phase. [native-inputs]: Add PYTHON-SPHINX and TEXINFO. [outputs]: Add the "doc" output. [properties]: Clear the inherited HIDDEN? property. * guix/build-system/cmake.scm (default-cmake): Use CMAKE-MINIMAL instead of CMAKE.
Diffstat (limited to 'guix/build-system/cmake.scm')
-rw-r--r--guix/build-system/cmake.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index ee116c5a4c..ca88fadddf 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -48,7 +48,7 @@
;; Do not use `@' to avoid introducing circular dependencies.
(let ((module (resolve-interface '(gnu packages cmake))))
- (module-ref module 'cmake)))
+ (module-ref module 'cmake-minimal)))
(define* (lower name
#:key source inputs native-inputs outputs system target