summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-11 20:44:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-10-11 20:55:44 +0300
commitfd15eb286e9b2effaf19a65e17e9e0e6d19b2111 (patch)
treef473df8fc095489ef2fa74b43d97014c014e0be3 /gnu
parent0a3e9bf62171b051656f24b81094064b479ebf2e (diff)
downloadguix-patches-fd15eb286e9b2effaf19a65e17e9e0e6d19b2111.tar
guix-patches-fd15eb286e9b2effaf19a65e17e9e0e6d19b2111.tar.gz
gnu: python-more-itertools: Fix building on 32-bit architectures.
* gnu/packages/python.scm (python-more-itertools)[arguments]: Add a custom phase to prevent overflowing on 32-bit architectures.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d63e263e3c..1667f4801b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -142,7 +142,8 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
- #:use-module (srfi srfi-1))
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26))
(define-public python-2.7
(package
@@ -13550,6 +13551,20 @@ file system events on Linux.")
(base32
"17h3na0rdh8xq30w4b9pizgkdxmm51896bxw600x84jflg9vaxn4"))))
(build-system python-build-system)
+ (arguments
+ `(,@(if (any (cute string-prefix? <> (or (%current-system)
+ (%current-target-system)))
+ '("armhf" "i686"))
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; This is required for 32-bit hardware.
+ ;; TODO: Try to remove this when upgrading.
+ (add-after 'unpack 'patch-test
+ (lambda _
+ (substitute* "more_itertools/tests/test_more.py"
+ (("10 \\*\\* 10") "9 ** 9"))
+ #t))))
+ '())))
(propagated-inputs
`(("python-six" ,python-six-bootstrap)))
(home-page "https://github.com/erikrose/more-itertools")