summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-07 20:09:54 +0100
committerMarius Bakke <marius@gnu.org>2020-11-07 20:09:54 +0100
commitfce5ce77d0eb74692ea1ee0082c0abe628690770 (patch)
tree34bbd9d91ef067406252c6b1c0edeb731ee49f3f /gnu
parent2e8a9db6efd67e5524eecae8c8d1482a9bce8004 (diff)
downloadguix-patches-fce5ce77d0eb74692ea1ee0082c0abe628690770.tar
guix-patches-fce5ce77d0eb74692ea1ee0082c0abe628690770.tar.gz
gnu: tzdata: Keep using the "fat" tzdata file format.
* gnu/packages/base.scm (tzdata)[arguments]: In #:make-flags, pass CPPFLAGS to preserve the same on-disk format as earlier releases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index e8f7bb5f9c..1e3f0f1f3f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1240,7 +1240,7 @@ command.")
"02g88pbw82zr36x9dz5ib4sq6bfq253yx5hbhnfyhp143naky1cv"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f
+ `(#:tests? #f
#:make-flags (let ((out (assoc-ref %outputs "out"))
(tmp (getenv "TMPDIR")))
(list (string-append "TOPDIR=" out)
@@ -1252,6 +1252,16 @@ command.")
(string-append "LIBDIR=" tmp "/lib")
(string-append "MANDIR=" tmp "/man")
+ ;; XXX: tzdata 2020b changed the on-disk format
+ ;; of the time zone files from 'fat' to 'slim'.
+ ;; Many packages (particularly evolution-data-server)
+ ;; can not yet handle the latter, so we stick with
+ ;; 'fat' for now.
+ ,@(if (version>=? (package-version this-package)
+ "2020b")
+ '("CPPFLAGS=-DZIC_BLOAT_DEFAULT='\"fat\"'")
+ '())
+
"AWK=awk"
"CC=gcc"))
#:modules ((guix build utils)