summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-20 10:09:51 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:41 +0100
commitfc9eb91b0cbf2130282433797235f175c2a19992 (patch)
treebaf478c68ffae47c4538ad8cc13249b2c26db215 /gnu
parentbae99a0c44bc3d7b5066d4a5392b1e7447560500 (diff)
downloadguix-patches-fc9eb91b0cbf2130282433797235f175c2a19992.tar
guix-patches-fc9eb91b0cbf2130282433797235f175c2a19992.tar.gz
gnu: go-golang-org-x-sys: Update to 0.21.0.
* gnu/packages/golang-build.scm (go-golang-org-x-sys): Update to 0.21.0. Change-Id: I0509e9aad319f55641807a28ebbd32b50cf34ede
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-build.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 121a4ca49a..e744d16e5a 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -307,20 +307,18 @@ cancelation for groups of goroutines working on subtasks of a common task
(license license:bsd-3)))
(define-public go-golang-org-x-sys
- (let ((commit "ca59edaa5a761e1d0ea91d6c07b063f85ef24f78")
- (revision "0"))
(package
(name "go-golang-org-x-sys")
- (version (git-version "0.8.0" revision commit))
+ (version "0.21.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://go.googlesource.com/sys")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1p81niiin8dwyrjl2xsc95136w3vdw4kmj0w3mlh0vh5v134s4xq"))))
+ (base32 "000fcyi863sbmamdn3cwfv3s3z9ls5l34xnjavcbgjs591ghki8y"))))
(build-system go-build-system)
(arguments
(list
@@ -339,7 +337,7 @@ cancelation for groups of goroutines working on subtasks of a common task
(synopsis "Go support for low-level system interaction")
(description "This package provides supplemental libraries offering Go
support for low-level interaction with the operating system.")
- (license license:bsd-3))))
+ (license license:bsd-3)))
(define-public go-golang-org-x-term
(package