summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-23 18:13:21 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:46 +0100
commitfb05eed9ef87956a0cf1d0f69d0585eb9c756888 (patch)
tree415d1855c1e8cc44c7191f41c696835f33c1b4db /gnu
parented88e67d56a471f6dd75266c2c79affa0c83664a (diff)
downloadguix-patches-fb05eed9ef87956a0cf1d0f69d0585eb9c756888.tar
guix-patches-fb05eed9ef87956a0cf1d0f69d0585eb9c756888.tar.gz
gnu: Add kspaceduel.
* gnu/packages/games.scm (kspaceduel): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1f9864ce8b..e5946dd8e8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9123,3 +9123,40 @@ taken to the next stage with slightly increased game speed
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public kspaceduel
+ (package
+ (name "kspaceduel")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kspaceduel-" version ".tar.xz"))
+ (sha256
+ (base32 "1hppni0ihs7psc0dly5rxyy2a38nzhlig9yfyhi3lkh36z05pql8"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Two player game with shooting spaceships flying around a sun")
+ (description "KSpaceduel is a space battle game for one or two players,
+where two ships fly around a star in a struggle to be the only survivor.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))