summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-07-05 18:34:09 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:14:13 +0200
commitf8dae88c1e5808394aca8a45a7433d60ee1b71bb (patch)
tree3ca061b9b395c847ab9525ea3c66543ee56d57b5 /gnu
parent1a1bce6b5dd1f1f3c566feb5146279d69a2c9483 (diff)
downloadguix-patches-f8dae88c1e5808394aca8a45a7433d60ee1b71bb.tar
guix-patches-f8dae88c1e5808394aca8a45a7433d60ee1b71bb.tar.gz
gnu: mkfontdir: Fix aarch64 cross-compilation.
The packaged config.sub and config.guess do not have aarch64 support. Replace them by the ones from automake. * gnu/packages/xorg.scm (mkfontdir)[arguments]: Replace outdated config.sub and config.guess, by the ones taken from ... [native-inputs]: ... here, by adding automake.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm19
1 files changed, 17 insertions, 2 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d7cd585664..d5d983a8d2 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2019 nee <nee@cock.li>
;;; Copyright © 2019 Yoshinori Arai <kumagusu08@gmail.com>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4742,8 +4743,21 @@ protocol and arbitrary X extension protocol.")
"0c3563kw9fg15dpgx4dwvl12qz6sdqdns1pxa574hc7i5m42mman"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-configure
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.sub and config.guess:
+ (for-each (lambda (file)
+ (install-file (string-append
+ (assoc-ref
+ (or native-inputs inputs) "automake")
+ "/share/automake-"
+ ,(version-major+minor
+ (package-version automake))
+ "/" file) "."))
+ '("config.sub" "config.guess"))
+ #t))
(add-after 'install 'wrap-mkfontdir
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (string-append (assoc-ref outputs "out")
@@ -4755,7 +4769,8 @@ protocol and arbitrary X extension protocol.")
(inputs
`(("mkfontscale" ,mkfontscale)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("automake" ,automake))) ;For up to date 'config.guess' and 'config.sub'.
(home-page "https://www.x.org/wiki/")
(synopsis "Create an index of X font files in a directory")
(description