summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-13 07:26:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-13 07:26:42 +0100
commitf7c03e452b25b86123e0a9478fdb5541f259ddee (patch)
tree13d25cb456ba9cc56116098792763471f9ca2a6d /gnu
parent971af38c897208a270bc334f137598a55fcc7628 (diff)
downloadguix-patches-f7c03e452b25b86123e0a9478fdb5541f259ddee.tar
guix-patches-f7c03e452b25b86123e0a9478fdb5541f259ddee.tar.gz
gnu: tcl, tk: Update to 8.6.7.
* gnu/packages/tcl.scm (tcl): Update to 8.6.7. [source]: Remove obsolete patch. (tk): Update to 8.6.7. * gnu/packages/patches/tcl-mkindex-deterministic.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/tcl-mkindex-deterministic.patch29
-rw-r--r--gnu/packages/tcl.scm9
3 files changed, 4 insertions, 35 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5418d1418d..d0a77c08bb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1055,7 +1055,6 @@ dist_patch_DATA = \
%D%/packages/patches/t1lib-CVE-2011-1552+CVE-2011-1553+CVE-2011-1554.patch \
%D%/packages/patches/tar-CVE-2016-6321.patch \
%D%/packages/patches/tar-skip-unreliable-tests.patch \
- %D%/packages/patches/tcl-mkindex-deterministic.patch \
%D%/packages/patches/tclxml-3.2-install.patch \
%D%/packages/patches/tcsh-fix-autotest.patch \
%D%/packages/patches/tcsh-fix-out-of-bounds-read.patch \
diff --git a/gnu/packages/patches/tcl-mkindex-deterministic.patch b/gnu/packages/patches/tcl-mkindex-deterministic.patch
deleted file mode 100644
index 2fcef6a4f7..0000000000
--- a/gnu/packages/patches/tcl-mkindex-deterministic.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-This patch ensures that the 'tclIndex' files generated by 'auto_mkindex'
-are sorted in a deterministic fashion.
-
-Fixes a non-determinism issue reported
-at <https://lists.gnu.org/archive/html/guix-devel/2015-10/msg00696.html>.
-
---- tcl8.6.4/library/auto.tcl 2015-02-26 17:57:28.000000000 +0100
-+++ tcl8.6.4/library/auto.tcl 2015-11-13 23:18:34.964831717 +0100
-@@ -207,6 +207,9 @@ proc auto_mkindex {dir args} {
- set args *.tcl
- }
-
-+ # Keep file names sorted in a determistic order.
-+ set args [lsort -ascii $args]
-+
- auto_mkindex_parser::init
- foreach file [glob -- {*}$args] {
- try {
-@@ -241,6 +244,10 @@ proc auto_mkindex_old {dir args} {
- if {![llength $args]} {
- set args *.tcl
- }
-+
-+ # Keep file names sorted in a determistic order.
-+ set args [lsort -ascii $args]
-+
- foreach file [glob -- {*}$args] {
- set f ""
- set error [catch {
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 8591ff808c..01649ff410 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -38,15 +38,14 @@
(define-public tcl
(package
(name "tcl")
- (version "8.6.6")
+ (version "8.6.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/tcl/Tcl/"
version "/tcl" version "-src.tar.gz"))
(sha256
(base32
- "01zypqhy57wvh1ikk28bg733sk5kf4q568pq9v6fvcz4h6bl0rd2"))
- (patches (search-patches "tcl-mkindex-deterministic.patch"))))
+ "19bb09l55alz4jb38961ikd5116q80s51bjvzqy44ckkwf28ysvw"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-before
@@ -137,14 +136,14 @@ X11 GUIs.")
(define-public tk
(package
(name "tk")
- (version "8.6.6")
+ (version "8.6.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/tcl/Tcl/"
version "/tk" version "-src.tar.gz"))
(sha256
(base32
- "17diivcfcwdhp4v5zi6j9nkxncccjqkivhp363c4wx5lf4d3fb6n"))
+ "1aipcf6qmbgi15av8yrpp2hx6vdwr684r6739p8cgdzrajiy4786"))
(patches (search-patches "tk-find-library.patch"))))
(build-system gnu-build-system)
(arguments