summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-15 19:30:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:49 +0200
commitf75aa97f9535170f581f780acec05a2c4298d4ba (patch)
tree47680841c97398d399621ae636e409b9f89db442 /gnu
parent82ff725df9f93fb5a864eec7803fdbb09f7f816b (diff)
downloadguix-patches-f75aa97f9535170f581f780acec05a2c4298d4ba.tar
guix-patches-f75aa97f9535170f581f780acec05a2c4298d4ba.tar.gz
gnu: Replace uses of texlive-*-amsfonts.
* gnu/packages/algebra.scm (pari-gp)[native-inputs]: Replace texlive-fonts-amsfonts and texlive-latex-amsfonts with texlive-amsfonts in texlive-union. * gnu/packages/docbook.scm (dblatex)[inputs]: Same. * gnu/packages/plotutils.scm (asymptote)[native-inputs]: Same. * gnu/packages/python-xyz.scm (python-numpy-documentation, python-matplotlib-documentation, python-ipython-documentation) [native-inputs]: Same. * gnu/packages/statistics.scm (r-with-tests)[native-inputs]: Same. * gnu/packages/tex.scm (teximpatient)[native-inputs]: Same.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm3
-rw-r--r--gnu/packages/docbook.scm3
-rw-r--r--gnu/packages/plotutils.scm3
-rw-r--r--gnu/packages/python-xyz.scm11
-rw-r--r--gnu/packages/statistics.scm5
-rw-r--r--gnu/packages/tex.scm3
6 files changed, 10 insertions, 18 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 1e21562e91..88fca62e4e 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -236,8 +236,7 @@ the real span of the lattice.")
(build-system gnu-build-system)
(native-inputs
`(("texlive" ,(texlive-union
- (list texlive-fonts-amsfonts
- texlive-latex-amsfonts)))))
+ (list texlive-amsfonts)))))
(inputs `(("gmp" ,gmp)
("libx11" ,libx11)
("perl" ,perl)
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 1e5379b020..d114e24ee7 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -195,7 +195,7 @@ by no means limited to these applications.) This package provides XML DTDs.")
(build-system python-build-system)
;; TODO: Add xfig/transfig for fig2dev utility
(inputs
- `(("texlive" ,(texlive-union (list texlive-latex-amsfonts
+ `(("texlive" ,(texlive-union (list texlive-amsfonts
texlive-latex-anysize
texlive-latex-appendix
texlive-latex-changebar
@@ -219,7 +219,6 @@ by no means limited to these applications.) This package provides XML DTDs.")
texlive-latex-url
texlive-latex-wasysym
- texlive-fonts-amsfonts
texlive-fonts-ec
texlive-fonts-rsfs
texlive-fonts-stmaryrd
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index b4ea20e387..88bc6b3dc6 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -198,8 +198,7 @@ colors, styles, options and details.")
("perl" ,perl)
("texinfo" ,texinfo) ;For generating documentation
;; For the manual and the tests.
- ("texlive" ,(texlive-union (list texlive-fonts-amsfonts
- texlive-latex-amsfonts
+ ("texlive" ,(texlive-union (list texlive-amsfonts
texlive-latex-geometry
texlive-latex-graphics
texlive-latex-oberdiek ; for ifluatex
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 362ab7f031..ca3e3b642b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3495,12 +3495,11 @@ color scales, and color space conversion easy. It has support for:
("pkg-config" ,pkg-config)
("python-sphinx" ,python-sphinx)
("python-numpydoc" ,python-numpydoc)
- ("texlive" ,(texlive-union (list texlive-fonts-amsfonts
- texlive-fonts-cm-super
+ ("texlive" ,(texlive-union (list texlive-fonts-cm-super
texlive-fonts-ec
texlive-generic-ifxetex
texlive-generic-pdftex
- texlive-latex-amsfonts
+ texlive-amsfonts
texlive-latex-capt-of
texlive-latex-cmap
texlive-latex-environ
@@ -3899,7 +3898,7 @@ toolkits.")
("python-ipykernel" ,python-ipykernel)
("python-mock" ,python-mock)
("graphviz" ,graphviz)
- ("texlive" ,(texlive-union (list texlive-latex-amsfonts
+ ("texlive" ,(texlive-union (list texlive-amsfonts
texlive-latex-amsmath
texlive-latex-enumitem
texlive-latex-expdlist
@@ -3910,7 +3909,6 @@ toolkits.")
texlive-generic-pdftex
- texlive-fonts-amsfonts
texlive-fonts-ec
texlive-fonts-adobe-times
texlive-fonts-txfonts)))
@@ -5467,11 +5465,10 @@ computing.")
`(("python-sphinx" ,python-sphinx)
("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
;; FIXME: It's possible that a smaller union would work just as well.
- ("texlive" ,(texlive-union (list texlive-fonts-amsfonts
+ ("texlive" ,(texlive-union (list texlive-amsfonts
texlive-fonts-ec
texlive-generic-ifxetex
texlive-generic-pdftex
- texlive-latex-amsfonts
texlive-latex-capt-of
texlive-latex-cmap
texlive-latex-environ
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index eb5e5b4b76..6ed1e40108 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -319,9 +319,8 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
("perl" ,perl)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo) ; for building HTML manuals
- ("texlive" ,(texlive-union (list texlive-fonts-amsfonts
- texlive-fonts-ec
- texlive-latex-amsfonts
+ ("texlive" ,(texlive-union (list texlive-fonts-ec
+ texlive-amsfonts
texlive-latex-base
texlive-latex-fancyvrb
texlive-latex-graphics
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ee404871fb..30eda2f846 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6646,8 +6646,7 @@ develop documents with LaTeX, in a single application.")
(delete-file "book.pdf")
#t)))))
(native-inputs
- `(("texlive" ,(texlive-union (list texlive-latex-amsfonts
- texlive-fonts-amsfonts
+ `(("texlive" ,(texlive-union (list texlive-amsfonts
texlive-fonts-adobe-palatino
texlive-fonts-adobe-zapfding
texlive-fonts-knuth-lib