summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-12 15:02:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-12 17:39:56 +0300
commitf58ba4031ffc73fbb0b1d1940229267bb1dd41f9 (patch)
treeb94b72d22b9262da4266150721e3fe66a0e8ebb0 /gnu
parent0d6d7b3efc8888f4cf6a5b785eb072e30bd91712 (diff)
downloadguix-patches-f58ba4031ffc73fbb0b1d1940229267bb1dd41f9.tar
guix-patches-f58ba4031ffc73fbb0b1d1940229267bb1dd41f9.tar.gz
gnu: bcachefs-tools: Only build with valgrind on supported systems.
* gnu/packages/file-systems.scm (bcachefs-tools)[native-inputs]: Only add valgrind on systems where valgrind is supported.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/file-systems.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 9f6ca10831..d77d3be068 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2017, 2018, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 raid5atemyhomework <raid5atemyhomework@protonmail.com>
@@ -447,13 +447,16 @@ from a mounted file system.")
(string-append #$util-linux "/bin"))))))))
#:tests? #f)) ; XXX 6 valgrind tests fail
(native-inputs
- (list pkg-config
- ;; For tests.
- python-pytest
- valgrind
- ;; For generating documentation with rst2man.
- python
- python-docutils))
+ (append
+ (list pkg-config
+ ;; For tests.
+ python-pytest)
+ (if (member (%current-system) (package-supported-systems valgrind))
+ (list valgrind)
+ '())
+ ;; For generating documentation with rst2man.
+ (list python
+ python-docutils)))
(inputs
(list eudev
keyutils