summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2021-03-29 16:04:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-12 16:03:51 +0200
commitf53ec9d99b035afba6db042949bff71f2d0fdb7b (patch)
tree8b35b6831d800143dafea56d1faa8fce4cf5cd79 /gnu
parente698843442b34185864f9bed6dc7b75b7254f29e (diff)
downloadguix-patches-f53ec9d99b035afba6db042949bff71f2d0fdb7b.tar
guix-patches-f53ec9d99b035afba6db042949bff71f2d0fdb7b.tar.gz
gnu: Add openvdb.
* gnu/packages/graphics.scm (openvdb): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 3c9cf18bbc..f9f19cc28d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
;;; Copyright © 2021 Andy Tai <atai@atai.org>
+;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -463,6 +464,42 @@ Embree is meant to increase performance of photo-realistic rendering
applications.")
(license license:asl2.0)))
+(define-public openvdb
+ (package
+ (name "openvdb")
+ (version "8.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AcademySoftwareFoundation/openvdb/")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qzx6l5c183k6j9zki31gg9aixf5s1j46wdi7wr1h3bz7k53syg9"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DCMAKE_EXE_LINKER_FLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib"))))
+ (inputs
+ `(("boost" ,boost)
+ ("c-blosc" ,c-blosc)
+ ("ilmbase" ,ilmbase)
+ ("tbb" ,tbb)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://www.openvdb.org/")
+ (synopsis "Sparse volume data structure and tools")
+ (description "OpenVDB is a C++ library comprising a hierarchical data
+structure and a large suite of tools for the efficient storage and
+manipulation of sparse volumetric data discretized on three-dimensional grids.
+It was developed by DreamWorks Animation for use in volumetric applications
+typically encountered in feature film production.")
+ (license license:mpl2.0)))
+
(define-public blender
(package
(name "blender")