summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-02-17 12:07:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-02-17 16:16:36 +0200
commitf499e12486cf69643ec8baa23530d9caad13502b (patch)
tree7b12e0cf6d4c1125bde036980a77356da3ee5e33 /gnu
parent4f8c551cf367c9b1f83e8b438df4764abaab2d41 (diff)
downloadguix-patches-f499e12486cf69643ec8baa23530d9caad13502b.tar
guix-patches-f499e12486cf69643ec8baa23530d9caad13502b.tar.gz
gnu: Add ruby-memory-profiler.
* gnu/packages/ruby.scm (ruby-memory-profiler): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8dab0b6e1d..3294b4e134 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7700,6 +7700,29 @@ Profiling multiple threads simultaneously is supported.
(home-page "https://github.com/ruby-prof/ruby-prof")
(license license:bsd-2)))
+(define-public ruby-memory-profiler
+ (package
+ (name "ruby-memory-profiler")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SamSaffron/memory_profiler")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07yqv11q68xg2fqkrhs6ysngryk8b9zq6qzh24rgx9xqv6qfnj0w"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-rake" ,ruby-rake)))
+ (synopsis "Memory profiling routines for Ruby")
+ (description
+ "This package provides memory profiling routines for Ruby.")
+ (home-page "https://github.com/SamSaffron/memory_profiler")
+ (license license:expat)))
+
(define-public ruby-cucumber-messages
(package
(name "ruby-cucumber-messages")