summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-04-17 21:47:06 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-04-18 08:36:30 +0200
commitf3f118402d828f5cf149eeb96dbd39b978feb75a (patch)
treef0986901a240e8476364d4b0be5837f0e1a87c38 /gnu
parent94db80b6d1e4dbb0bfd55e27d6e7fb2cb34d90cc (diff)
downloadguix-patches-f3f118402d828f5cf149eeb96dbd39b978feb75a.tar
guix-patches-f3f118402d828f5cf149eeb96dbd39b978feb75a.tar.gz
gnu: python-tifffile: Update to 2021.4.8.
* gnu/packages/python-xyz.scm (python-tifffile) [version]: Update to 2021.4.8. [propagated-inputs]: Drop python-roifiles, which is only required for tests (disabled). Add python-imagecodecs, which allows decoding compressed tiff files.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b341d7cd75..538435fdc4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6189,21 +6189,20 @@ regions of interest, geometric shapes, paths, text, etc for image overlays.")
(define-public python-tifffile
(package
(name "python-tifffile")
- (version "2020.6.3")
+ (version "2021.4.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tifffile" version))
(sha256
(base32
- "0xv3ynkbrsibqvx7250075idb7wm3canjd6lx2nzf3cbp6l07577"))))
+ "16r0hw7shka1bqf28bv198lj2jhf2r9gy3s5zv4nf5cfsfm8pajm"))))
(build-system python-build-system)
;; Tests require lfdfiles, which depends on tifffile
(arguments `(#:tests? #f))
(propagated-inputs
`(("python-numpy" ,python-numpy)
- ;;("python-lfdfiles" ,python-lfdfiles)
- ("python-roifile" ,python-roifile)))
+ ("python-imagecodecs" ,python-imagecodecs)))
(home-page "https://www.lfd.uci.edu/~gohlke/")
(synopsis "Read and write TIFF(r) files")
(description "This package lets you read image and metadata from many