summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-05-03 23:25:44 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-07 18:16:59 +0200
commitf2a94a9e26250953b4f02c4b87998f4168208052 (patch)
tree123d3dec7e85ddfe22fcbce087830a982f7209fc /gnu
parentf1b0d0d76f196f3c9df1ecb0587f9f833bb37d82 (diff)
downloadguix-patches-f2a94a9e26250953b4f02c4b87998f4168208052.tar
guix-patches-f2a94a9e26250953b4f02c4b87998f4168208052.tar.gz
gnu: Add dsdcc.
* gnu/packages/radio.scm (dsdcc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/radio.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 8af4149c69..16a9aacaed 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1702,3 +1702,43 @@ Codec.")
(description "This is a library to decode @acronym{DAB/DAB+, Digital
Audio Broadcasting}.")
(license license:gpl2+))))
+
+(define-public dsdcc
+ (package
+ (name "dsdcc")
+ (version "1.9.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/f4exb/dsdcc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jgzpv4d6ckd0sdq6438rjh3m6knj6gx63627fajch74hxrvclzj"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("mbelib" ,mbelib)
+ ("serialdv" ,serialdv)))
+ (arguments
+ `(#:tests? #f ; No test suite.
+ #:configure-flags
+ (list "-DUSE_MBELIB=ON"
+ (string-append "-DLIBMBE_INCLUDE_DIR="
+ (assoc-ref %build-inputs "mbelib")
+ "/include")
+ (string-append "-DLIBMBE_LIBRARY="
+ (assoc-ref %build-inputs "mbelib")
+ "/lib/libmbe.so")
+ (string-append "-DLIBSERIALDV_INCLUDE_DIR="
+ (assoc-ref %build-inputs "serialdv")
+ "/include/serialdv")
+ (string-append "-DLIBSERIALDV_LIBRARY="
+ (assoc-ref %build-inputs "serialdv")
+ "/lib/libserialdv.so"))))
+ (home-page "https://github.com/f4exb/dsdcc")
+ (synopsis "Digital speech decoder")
+ (description
+ "This package provides a library and a program to decode several digital
+voice formats.")
+ (license license:gpl3+)))