summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-29 21:21:29 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-29 23:15:53 +0100
commitede2e1f43457ef91f208a555de0a659f0727a9e1 (patch)
tree96cc21a8a0a30ca2b87de3c5ca0c7ddfc45b3013 /gnu
parenta79041f0b583ef3399bb46ac2a6c03a4db636573 (diff)
downloadguix-patches-ede2e1f43457ef91f208a555de0a659f0727a9e1.tar
guix-patches-ede2e1f43457ef91f208a555de0a659f0727a9e1.tar.gz
gnu: libtermkey: Prepare for cross-compilation.
* gnu/packages/terminals.scm (libtermkey)[arguments]: Use CC-FOR-TARGET.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/terminals.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index f6ad90024b..44859879a7 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -48,6 +48,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages check)
@@ -348,8 +349,8 @@ multi-seat support, a replacement for @command{mingetty}, and more.")
(base32 "0psd0kf10q5ixfima0mxz10syy7qq1ilz1npr0rz862xycvzgjyf"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags (list
- "CC=gcc"
+ `(#:make-flags (list
+ (string-append "CC=" ,(cc-for-target))
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases (modify-phases %standard-phases
(delete 'configure)) ; no configure script