summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 09:54:47 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commitec5dbb5c30ffbde60fb93f91c9149076e498b581 (patch)
treed992fda7be2e811deeceb4b2db9c27199a777d0c /gnu
parent2cec1f6f56da12886d2c753ee96e74a50404e70a (diff)
downloadguix-patches-ec5dbb5c30ffbde60fb93f91c9149076e498b581.tar
guix-patches-ec5dbb5c30ffbde60fb93f91c9149076e498b581.tar.gz
gnu: Add python-itsdangerous.
* gnu/packages/python.scm (python-itsdangerous, python2-itsdangerous): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 72b42e3590..6ba8c243f4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1643,3 +1643,29 @@ OAuth request-signing logic.")
(inputs
(append (package-inputs base)
`(("python2-unittest2" ,python2-unittest2)))))))
+
+(define-public python-itsdangerous
+ (package
+ (name "python-itsdangerous")
+ (version "0.24")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/i/itsdangerous/itsdangerous-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "06856q6x675ly542ig0plbqcyab6ksfzijlyf1hzhgg3sgwgrcyb"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://github.com/mitsuhiko/itsdangerous")
+ (synopsis "Python library for passing data to/from untrusted environments")
+ (description
+ "Itsdangerous provides various helpers to pass trusted data to untrusted
+environments and back.")
+ (license bsd-3)))
+
+(define-public python2-itsdangerous
+ (package-with-python2 python-itsdangerous))