summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-01-09 08:55:03 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-02-07 15:17:55 +0100
commiteaa998577bba954b121f296f84b8b65e5ca2ec04 (patch)
tree018b641df1da4e81e720b893a6963887c84c49e3 /gnu
parentb4d71a62ade12df6a28487ff308fb3fa0ef1fcbb (diff)
downloadguix-patches-eaa998577bba954b121f296f84b8b65e5ca2ec04.tar
guix-patches-eaa998577bba954b121f296f84b8b65e5ca2ec04.tar.gz
gnu: python2-renpy: Update to 7.4.0.
* gnu/packages/game-development.scm (python2-renpy): Update to 7.4.0. (inputs): Move python2-pygame... (propagated-inputs): ... to here. Add python2-future. (#:phases)[install]: Infer python version from input. * gnu/packages/patches/renpy-use-system-fribidi.patch: Update to renpy 7.4.0. python2-renpy: propagate python inputs
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm13
-rw-r--r--gnu/packages/patches/renpy-use-system-fribidi.patch23
2 files changed, 21 insertions, 15 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index f1818e54e8..d8ea29b408 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1141,13 +1141,13 @@ developed mainly for Ren'py.")
(define-public python2-renpy
(package
(name "python2-renpy")
- (version "7.3.5")
+ (version "7.4.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.renpy.org/dl/" version
"/renpy-" version "-source.tar.bz2"))
- (sha256 (base32 "1anr5cfbvbsbik4v4rvrkdkciwhg700k4lydfbs4n85raimz9mw4"))
+ (sha256 (base32 "0av3mbh54xh6i3rvf60x5hbsjcfpzgia2j958mhyc5826zjxzfpg"))
(modules '((guix build utils)))
(patches
(search-patches
@@ -1204,8 +1204,8 @@ developed mainly for Ren'py.")
;; (both source and compiled) in the same directory.
(let* ((out (assoc-ref outputs "out"))
(site (string-append "/lib/python"
- ,(version-major+minor
- (package-version python-2))
+ (python-version
+ (assoc-ref inputs "python"))
"/site-packages")))
(with-directory-excursion "module"
(apply (assoc-ref %standard-phases 'install) args))
@@ -1218,9 +1218,11 @@ developed mainly for Ren'py.")
("fribidi" ,fribidi)
("glew" ,glew)
("libpng" ,libpng)
- ("python2-pygame" ,python2-pygame-sdl2)
("sdl-union"
,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
+ (propagated-inputs
+ `(("python2-future" ,python2-future)
+ ("python2-pygame" ,python2-pygame-sdl2)))
(native-inputs
`(("python2-cython" ,python2-cython)
("xdg-utils" ,xdg-utils)))
@@ -1234,7 +1236,6 @@ modules of Ren'py.")
(package
(inherit python2-renpy)
(name "renpy")
- (version "7.3.5")
(build-system python-build-system)
(arguments
`(#:tests? #f ; see python2-renpy
diff --git a/gnu/packages/patches/renpy-use-system-fribidi.patch b/gnu/packages/patches/renpy-use-system-fribidi.patch
index 1437274bcc..913415e317 100644
--- a/gnu/packages/patches/renpy-use-system-fribidi.patch
+++ b/gnu/packages/patches/renpy-use-system-fribidi.patch
@@ -2,22 +2,27 @@ See also [Arch] and [Gentoo] for similar patches in other distros.
[Arch] https://github.com/archlinux/svntogit-community/blob/packages/renpy/trunk/renpy-system-fribidi.patch
[Gentoo] https://gitweb.gentoo.org/repo/gentoo.git/tree/games-engines/renpy/files/renpy-7.3.5-use-system-fribidi.patch
-Index: renpy-7.3.5-source/module/renpybidicore.c
+Index: renpy-7.4.0-source/module/renpybidicore.c
===================================================================
---- renpy-7.3.5-source.orig/module/renpybidicore.c
-+++ renpy-7.3.5-source/module/renpybidicore.c
-@@ -1,5 +1,5 @@
+--- renpy-7.4.0-source.orig/module/renpybidicore.c
++++ renpy-7.4.0-source/module/renpybidicore.c
+@@ -1,9 +1,3 @@
#include <Python.h>
+-
+-#ifdef RENPY_BUILD
+ #include <fribidi.h>
+-#else
-#include <fribidi-src/lib/fribidi.h>
-+#include <fribidi.h>
+-#endif
+-
#include <stdlib.h>
#ifndef alloca
-Index: renpy-7.3.5-source/module/setup.py
+Index: renpy-7.4.0-source/module/setup.py
===================================================================
---- renpy-7.3.5-source.orig/module/setup.py
-+++ renpy-7.3.5-source/module/setup.py
-@@ -119,30 +119,13 @@ cython(
+--- renpy-7.4.0-source.orig/module/setup.py
++++ renpy-7.4.0-source/module/setup.py
+@@ -125,30 +125,13 @@ cython(
sdl + [ png, 'z', 'm' ])
FRIBIDI_SOURCES = """