summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJesse Gibbons <jgibbons2357+guix@gmail.com>2020-07-03 16:54:21 -0600
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-08-12 17:08:40 +0200
commite7e69e56f59546efce6ffd8e7d3cbee70970930c (patch)
tree0f6faad4bbb2f8a47060bae667ec8453f3c18cf9 /gnu
parente77989bdcb4c939aa1128ec0d3efc9ac8369fa15 (diff)
downloadguix-patches-e7e69e56f59546efce6ffd8e7d3cbee70970930c.tar
guix-patches-e7e69e56f59546efce6ffd8e7d3cbee70970930c.tar.gz
gnu: freedink-engine: Call autoreconf.
* gnu/packages/games.scm: freedink-engine (phases): add 'autoreconf Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 82a9660b2a..e8cb012fba 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2745,6 +2745,14 @@ interface or via an external visual interface such as GNU XBoard.")
;; These tests require a graphical interface.
(substitute* "src/Makefile.am"
(("test_gfx_fonts TestIOGfxDisplay") ""))
+ #t))
+ (add-before 'bootstrap 'autoreconf
+ (lambda _
+ ;; automake is out of date in the source
+ ;; autoreconf updates the automake scripts
+ (invoke "autoreconf")
+ ;; Build fails when autom4te.cache exists.
+ (delete-file-recursively "autom4te.cache")
#t)))))
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)