summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-19 22:44:19 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:40 +0100
commite7349f1f8155b714b757a716439827578e2f6cec (patch)
tree8d316a124fc5d16080a859af867f6358febe54fb /gnu
parent6d520b8c0c8ac562f8275cbb8f77bf6ebacd2444 (diff)
downloadguix-patches-e7349f1f8155b714b757a716439827578e2f6cec.tar
guix-patches-e7349f1f8155b714b757a716439827578e2f6cec.tar.gz
gnu: nncp: Apply "-trimpath" flag.
* gnu/packages/uucp.scm (nncp) [arguments]: <#:phases>: Remove 'remove-go-references phase. Set BUILDFLAGS=-trimpath to replace 'remove-go-references phase in 'configure phase. Change-Id: I7cfe14174e38708d36329d8e33ed6bb1ce0ae220
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/uucp.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/uucp.scm b/gnu/packages/uucp.scm
index 8e47834fef..d8eb17111d 100644
--- a/gnu/packages/uucp.scm
+++ b/gnu/packages/uucp.scm
@@ -116,6 +116,7 @@ between computers.")
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
+ (setenv "GO_LDFLAGS" "-trimpath")
;; Set configuration path.
(setenv "CFGPATH" "/etc/nncp.hjson")
;; Set output directories.
@@ -142,9 +143,7 @@ between computers.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "contrib/do" "-c" "test"))))
- (add-after 'install 'remove-go-references
- (assoc-ref go:%standard-phases 'remove-go-references)))))
+ (invoke "contrib/do" "-c" "test")))))))
(inputs
(list go-github-com-davecgh-go-xdr
go-github-com-dustin-go-humanize