summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-10 17:15:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-10 17:15:32 +0200
commite43e980f847564e46f96e09bf77c648c3ef98b3c (patch)
treeaa1bf1115c57e3b4db740aac918aec1ea64a5eec /gnu
parent29c6fb0d33b3bea8677093eed1cfbd6483c9fbe8 (diff)
downloadguix-patches-e43e980f847564e46f96e09bf77c648c3ef98b3c.tar
guix-patches-e43e980f847564e46f96e09bf77c648c3ef98b3c.tar.gz
gnu: aegisub: Fix build with Make 4.3.
* gnu/packages/patches/aegisub-make43.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/video.scm (aegisub)[source](patches): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/patches/aegisub-make43.patch20
-rw-r--r--gnu/packages/video.scm1
3 files changed, 23 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2197ae5775..b10c856721 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -722,7 +722,8 @@ dist_patch_DATA = \
%D%/packages/patches/aegis-test-fixup-1.patch \
%D%/packages/patches/aegis-test-fixup-2.patch \
%D%/packages/patches/aegisub-icu59-include-unistr.patch \
- %D%/packages/patches/aegisub-boost68.patch \
+ %D%/packages/patches/aegisub-boost68.patch \
+ %D%/packages/patches/aegisub-make43.patch \
%D%/packages/patches/agg-am_c_prototype.patch \
%D%/packages/patches/akonadi-paths.patch \
%D%/packages/patches/akonadi-Revert-Make-installation-properly-relo.patch \
diff --git a/gnu/packages/patches/aegisub-make43.patch b/gnu/packages/patches/aegisub-make43.patch
new file mode 100644
index 0000000000..32f9d7749c
--- /dev/null
+++ b/gnu/packages/patches/aegisub-make43.patch
@@ -0,0 +1,20 @@
+Fix build with GNU Make 4.3:
+
+https://github.com/Aegisub/Aegisub/issues/171
+
+Patch taken from upstream:
+
+https://github.com/Aegisub/Aegisub/commit/6bd3f4c26b8fc1f76a8b797fcee11e7611d59a39
+
+diff --git a/Makefile.target b/Makefile.target
+--- a/Makefile.target
++++ b/Makefile.target
+@@ -112,7 +112,7 @@ POST_FLAGS = $($@_FLAGS) -c -o $@ $<
+ # Libraries contain all object files they depend on (but they may depend on other files)
+ # Not using libtool on OS X because it has an unsilenceable warning about a
+ # compatibility issue with BSD 4.3 (wtf)
+-lib%.a: $$($$*_OBJ)
++lib%.a: $$($$(*F)_OBJ)
+ @$(BIN_MKDIR_P) $(dir $@)
+ $(BIN_AR) cru $@ $(filter %.o,$^)
+ $(BIN_RANLIB) $@
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index cbdc5fb78a..16fd93415b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3249,6 +3249,7 @@ programmers to access a standard API to open and decompress media files.")
(base32
"11b83qazc8h0iidyj1rprnnjdivj1lpphvpa08y53n42bfa36pn5"))
(patches (search-patches "aegisub-icu59-include-unistr.patch"
+ "aegisub-make43.patch"
"aegisub-boost68.patch"))))
(build-system gnu-build-system)
(arguments