summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 15:59:13 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:26 +0300
commite3997ad79712f2c08f5fe23c1744456ac8d0eedf (patch)
treef23cf1b5b7a7a03c1b493d0b73aa7f98f4d4844f /gnu
parentded1792ef4b377d441774eea77936192909edaa7 (diff)
downloadguix-patches-e3997ad79712f2c08f5fe23c1744456ac8d0eedf.tar
guix-patches-e3997ad79712f2c08f5fe23c1744456ac8d0eedf.tar.gz
gnu: Add go-github-com-twpayne-go-xdg.
* gnu/packages/golang.scm (go-github-com-twpayne-go-xdg): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 48ff32a02c..1c5464c309 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5460,3 +5460,28 @@ and @code{ioutil} packages that is easy to test.")
"Package @code{vfsafero} provides a compatibility later between
@code{go-github-com-twpayne-go-vfs} and @code{go-github-com-spf13-afero}.")
(license license:expat)))
+
+(define-public go-github-com-twpayne-go-xdg
+ (package
+ (name "go-github-com-twpayne-go-xdg")
+ (version "3.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/twpayne/go-xdg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0j8q7yzixs6jlaad0lpa8hs6b240gm2cmy0yxgnprrbpa0y2r7ln"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/twpayne/go-xdg/v3"))
+ (native-inputs
+ `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+ ("go-github-com-twpayne-go-vfs" ,go-github-com-twpayne-go-vfs)))
+ (home-page "https://github.com/twpayne/go-xdg/")
+ (synopsis "Functions related to freedesktop.org")
+ (description "Package @code{xdg} provides functions related to
+@uref{freedesktop.org}.")
+ (license license:expat)))