summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-06-15 10:12:42 -0400
committerLeo Famulari <leo@famulari.name>2021-06-16 12:40:17 -0400
commite26efac68cb460bd70642668d35c806199888173 (patch)
treedf4335bba1f54bf7c329c2c59c52e503879a06b7 /gnu
parent0ee552553796bf49a5ed5a44ab37be4dc7c9082c (diff)
downloadguix-patches-e26efac68cb460bd70642668d35c806199888173.tar
guix-patches-e26efac68cb460bd70642668d35c806199888173.tar.gz
gnu: HexChat: Add Libera Chat to the list of networks.
* gnu/packages/patches/hexchat-add-libera-chat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/messaging.scm (hexchat)[source]: Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/messaging.scm1
-rw-r--r--gnu/packages/patches/hexchat-add-libera-chat.patch76
3 files changed, 78 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 953bff96d4..500973f9fe 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1220,6 +1220,7 @@ dist_patch_DATA = \
%D%/packages/patches/hdf-eos5-remove-gctp.patch \
%D%/packages/patches/hdf-eos5-fix-szip.patch \
%D%/packages/patches/hdf-eos5-fortrantests.patch \
+ %D%/packages/patches/hexchat-add-libera-chat.patch \
%D%/packages/patches/http-parser-CVE-2020-8287.patch \
%D%/packages/patches/hubbub-sort-entities.patch \
%D%/packages/patches/hurd-cross.patch \
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 499b7a8f3a..fe678d89fd 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -677,6 +677,7 @@ used by Pidgin and Bitlbee, among others, to access
(method url-fetch)
(uri (string-append "https://dl.hexchat.net/hexchat/hexchat-"
version ".tar.xz"))
+ (patches (search-patches "hexchat-add-libera-chat.patch"))
(sha256
(base32
"10p829jm1r6kidkgf5lhqhyqc5mxdcq96q3zhadsckasvc9rs6lh"))))
diff --git a/gnu/packages/patches/hexchat-add-libera-chat.patch b/gnu/packages/patches/hexchat-add-libera-chat.patch
new file mode 100644
index 0000000000..2bbb3137ba
--- /dev/null
+++ b/gnu/packages/patches/hexchat-add-libera-chat.patch
@@ -0,0 +1,76 @@
+Add libera.chat to the list of available networks and make it the
+default.
+
+Patches copied from upstream source repository:
+
+https://github.com/hexchat/hexchat/commit/a25f2381689d2c2279a0e43b33f6c0ec8305a096
+https://github.com/hexchat/hexchat/commit/d3545f37cd5f551ed8bc0ab7b20e5c8140adc0a6
+
+From a25f2381689d2c2279a0e43b33f6c0ec8305a096 Mon Sep 17 00:00:00 2001
+From: Panagiotis Vasilopoulos <hello@alwayslivid.com>
+Date: Wed, 19 May 2021 16:25:16 +0300
+Subject: [PATCH] Add Libera Chat to network list
+
+---
+ src/common/servlist.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/common/servlist.c b/src/common/servlist.c
+index e44a3f2df..33bd80f2d 100644
+--- a/src/common/servlist.c
++++ b/src/common/servlist.c
+@@ -239,6 +239,9 @@ static const struct defaultserver def[] =
+ /* Self signed */
+ {0, "irc.librairc.net"},
+
++ {"Libera Chat", 0, 0, 0, LOGIN_SASL, 0, TRUE},
++ {0, "irc.libera.chat"},
++
+ #ifdef USE_OPENSSL
+ {"LinkNet", 0},
+ {0, "irc.link-net.org/+7000"},
+From d3545f37cd5f551ed8bc0ab7b20e5c8140adc0a6 Mon Sep 17 00:00:00 2001
+From: Patrick Griffis <pgriffis@igalia.com>
+Date: Sun, 23 May 2021 21:15:43 -0500
+Subject: [PATCH] Change default network to Libera.Chat
+
+---
+ src/common/servlist.c | 4 ++--
+ src/fe-gtk/joind.c | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/common/servlist.c b/src/common/servlist.c
+index de75c8b9a..93557f975 100644
+--- a/src/common/servlist.c
++++ b/src/common/servlist.c
+@@ -240,7 +240,7 @@ static const struct defaultserver def[] =
+ /* Self signed */
+ {0, "irc.librairc.net"},
+
+- {"Libera Chat", 0, 0, 0, LOGIN_SASL, 0, TRUE},
++ {"Libera.Chat", 0, 0, 0, LOGIN_SASL, 0, TRUE},
+ {0, "irc.libera.chat"},
+
+ #ifdef USE_OPENSSL
+@@ -942,7 +942,7 @@ servlist_load_defaults (void)
+ {
+ int i = 0, j = 0;
+ ircnet *net = NULL;
+- guint def_hash = g_str_hash ("freenode");
++ guint def_hash = g_str_hash ("Libera.Chat");
+
+ while (1)
+ {
+diff --git a/src/fe-gtk/joind.c b/src/fe-gtk/joind.c
+index f1d3da504..ce3cbcaec 100644
+--- a/src/fe-gtk/joind.c
++++ b/src/fe-gtk/joind.c
+@@ -247,7 +247,7 @@ joind_show_dialog (server *serv)
+ G_CALLBACK (joind_ok_cb), serv);
+
+ if (serv->network)
+- if (g_ascii_strcasecmp(((ircnet*)serv->network)->name, "freenode") == 0)
++ if (g_ascii_strcasecmp(((ircnet*)serv->network)->name, "Libera.Chat") == 0)
+ {
+ gtk_entry_set_text (GTK_ENTRY (entry1), "#hexchat");
+ }