summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 11:58:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:44 +0200
commite0b4cf6019f520aef4c3d0ea9858a8f1fa215d22 (patch)
tree677a657ba598c5ea05e1eebecaa1545edf18a569 /gnu
parent9e4adea8adca392beaac705c10111639b8c51951 (diff)
downloadguix-patches-e0b4cf6019f520aef4c3d0ea9858a8f1fa215d22.tar
guix-patches-e0b4cf6019f520aef4c3d0ea9858a8f1fa215d22.tar.gz
gnu: texlive-latex-mdwtools -> texlive-mdwtools.
* gnu/packages/tex.scm (texlive-mdwtools): New variable. (texlive-latex-mdwtools): Deprecate variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 15 insertions, 12 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dbda741838..8a83033a03 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6048,19 +6048,19 @@ ability to communicate the paper size it's set up to the output.")
(define-deprecated-package texlive-latex-geometry texlive-geometry)
-(define-public texlive-latex-mdwtools
+(define-public texlive-mdwtools
(package
- (name "texlive-latex-mdwtools")
+ (name "texlive-mdwtools")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "mdwtools"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0caxs74hla28hc67csf5i5ahadx97w8vxh3mdmsprxbpd1mr7ssg"))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mdwtools/"
+ "source/latex/mdwtools/"
+ "tex/latex/mdwtools/")
+ (base32
+ "08wyw0k6r3fv7vdgwbcpq9ckifldy17fzhpar51s1qn0yib93zdg")))
(build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/mdwtools"))
+ (outputs '("out" "doc"))
(home-page "https://www.ctan.org/pkg/mdwtools")
(synopsis "Miscellaneous tools by Mark Wooding")
(description
@@ -6068,10 +6068,13 @@ ability to communicate the paper size it's set up to the output.")
starting with @code{@@}, macros to sanitize the OT1 encoding of the
@code{cmtt} fonts; a @code{doafter} command; improved @code{footnote} support;
@code{mathenv} for various alignment in maths; list handling; @code{mdwmath}
-which adds some minor changes to LaTeX maths; a rewrite of LaTeX's tabular and
-array environments; verbatim handling; and syntax diagrams.")
+which adds some minor changes to LaTeX maths; a rewrite of LaTeX's
+@code{tabular} and @code{array} environments; verbatim handling; and syntax
+diagrams.")
(license license:gpl3+)))
+(define-deprecated-package texlive-latex-mdwtools texlive-mdwtools)
+
(define-public texlive-makecmds
(package
(inherit (simple-texlive-package