summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:23:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:42 +0200
commitdf32f2e16a1318e5b87cdd21d00b9a841c795525 (patch)
tree75599fed4624677c76ccc43d088a39049b1e1649 /gnu
parent78369eab12488cf796d71e5c3c3d1ffccbf33457 (diff)
downloadguix-patches-df32f2e16a1318e5b87cdd21d00b9a841c795525.tar
guix-patches-df32f2e16a1318e5b87cdd21d00b9a841c795525.tar.gz
gnu: Add texlive-mpgraphics.
* gnu/packages/tex.scm (texlive-mpgraphics): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c131873c6b..d0eecae9ad 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5725,6 +5725,30 @@ colour names from different colour sets in different colour models available
to MetaPost.")
(license license:lppl)))
+(define-public texlive-mpgraphics
+ (package
+ (name "texlive-mpgraphics")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mpgraphics/"
+ "source/latex/mpgraphics/"
+ "tex/latex/mpgraphics/")
+ (base32
+ "0z51scc8vimwihdyxv3g1cb7bjbj8w2a2ck1ygjyf8xzz4hcic2s")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mpgraphics")
+ (synopsis "Process and display MetaPost figures inline")
+ (description
+ "The package allows LaTeX users to typeset MetaPost code inline and
+display figures in their documents with only and only one run of LaTeX,
+pdfLaTeX or XeLaTeX (no separate runs of @command{mpost}). Mpgraphics
+achieves this by using the shell escape (@samp{\\write 18}) feature of current
+TeX distributions, so that the whole process is automatic and the end user is
+saved the tiresome processing.")
+ (license license:lppl1.3+)))
+
(define-public texlive-natbib
(package
(name "texlive-natbib")