summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-05-12 11:53:02 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-19 08:55:51 +0200
commitde444e0294ca3c4186cf9409a6d8a551434083ce (patch)
treeea1147eab8b67818b48f182f54c3f2284ad11760 /gnu
parentb7c7a61dd614beeaa9329cf5cf98561adc4f4b06 (diff)
downloadguix-patches-de444e0294ca3c4186cf9409a6d8a551434083ce.tar
guix-patches-de444e0294ca3c4186cf9409a6d8a551434083ce.tar.gz
gnu: Add qcustomplot.
* gnu/packages/qt.scm (qcustomplot): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index b206deaeba..55855fb68a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2604,6 +2605,56 @@ color-related widgets.")
;; Includes a license exception for combining with GPL2 code.
(license license:lgpl3+))))
+(define-public qcustomplot
+ (package
+ (name "qcustomplot")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.qcustomplot.com/release/"
+ version "fixed" "/QCustomPlot.tar.gz"))
+ (sha256
+ (base32 "1324kqyj1v1f8k8d7b15gc3apwz9qxx52p86hvchg33hjdlqhskx"))))
+ (native-inputs
+ `(("qcustomplot-sharedlib"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "https://www.qcustomplot.com/release/"
+ version "fixed" "/QCustomPlot-sharedlib.tar.gz"))
+ (sha256
+ (base32 "0vp8lpxvd1nlp4liqrlvslpqrgfn0wpiwizzdsjbj22zzb8vxikc"))))))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-extra-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "tar" "-xvf" (assoc-ref inputs "qcustomplot-sharedlib"))))
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (chdir "qcustomplot-sharedlib/sharedlib-compilation")
+ (substitute* "sharedlib-compilation.pro"
+ ;; Don't build debug library.
+ (("debug_and_release")
+ "release"))
+ (invoke "qmake"
+ (string-append "DESTDIR="
+ (assoc-ref outputs "out")
+ "/lib"))))
+ (add-after 'install 'install-header
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "../../qcustomplot.h"
+ (string-append (assoc-ref outputs "out")
+ "/include")))))))
+ (home-page "https://www.qcustomplot.com/")
+ (synopsis "Qt widget for plotting and data visualization")
+ (description
+ "QCustomPlot is a Qt C++ widget providing 2D plots, graphs and charts.")
+ (license license:gpl3+)))
+
(define-public python-shiboken-2
(package
(name "python-shiboken-2")