summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2020-11-22 14:31:11 +0100
committerArun Isaac <arunisaac@systemreboot.net>2020-11-23 23:49:40 +0530
commitddfaae3136e842dcd910e6a1f5f170bae57e6e9a (patch)
tree64bca4fb4a9342ac8f8dc78f7d59d98e05f9b0fc /gnu
parent44110297772ae6f2065614af4e81564650369859 (diff)
downloadguix-patches-ddfaae3136e842dcd910e6a1f5f170bae57e6e9a.tar
guix-patches-ddfaae3136e842dcd910e6a1f5f170bae57e6e9a.tar.gz
gnu: Add emacs-orderless.
* gnu/packages/emacs-xyz.scm (emacs-orderless): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 885487bf17..998aef87a3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6770,6 +6770,29 @@ marginal benefit compared to the additional complexity of a new
interface.")
(license license:expat)))
+(define-public emacs-orderless
+ (package
+ (name "emacs-orderless")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oantolin/orderless")
+ (commit version)))
+ (sha256
+ (base32 "032lfwflkpaxbcxl4jf438vapswsdagipjczcn30sc4dfdh3p42c"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/oantolin/orderless")
+ (synopsis "Emacs completion style that matches multiple regexps in any order")
+ (description "This package provides an orderless completion style that
+divides the pattern into space-separated components, and matches candidates
+that match all of the components in any order. Each component can match in
+any one of several ways: literally, as a regexp, as an initialism, in the flex
+style, or as multiple word prefixes.")
+ (license license:gpl3+)))
+
(define-public emacs-smartparens
(package
(name "emacs-smartparens")