summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-12 12:58:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-12 13:03:33 +0100
commitddc1cddded1c643368023175d141ba80d87fd32e (patch)
tree98341dfba8863a7c2fd5eab1e34489606042e089 /gnu
parent825cc7e0d4bc7f052831f905a92945678441fb55 (diff)
downloadguix-patches-ddc1cddded1c643368023175d141ba80d87fd32e.tar
guix-patches-ddc1cddded1c643368023175d141ba80d87fd32e.tar.gz
gnu: snakemake: Update to 5.32.2.
* gnu/packages/python-xyz.scm (snakemake): Update to 5.32.2. [arguments]: Adjust patch in call-wrapper-not-wrapped-snakemake.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4dae9eee9e..361626a128 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7942,13 +7942,13 @@ Python.")
(define-public snakemake
(package
(name "snakemake")
- (version "5.7.1")
+ (version "5.32.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "snakemake" version))
(sha256
- (base32 "1pnpvvn8n2a78cg360wz3ldmpqrsm2wzi0c0dmvki9fnsw6fxdas"))))
+ (base32 "13013gdavwvyj1qr9xfi9fpwhb3km8c3z53bja5b7ic3sb2z6dgz"))))
(build-system python-build-system)
(arguments
;; TODO: Package missing test dependencies.
@@ -7960,7 +7960,7 @@ Python.")
;; this by calling the snakemake wrapper instead.
(add-after 'unpack 'call-wrapper-not-wrapped-snakemake
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* "snakemake/executors.py"
+ (substitute* "snakemake/executors/__init__.py"
(("\\{sys.executable\\} -m snakemake")
(string-append (assoc-ref outputs "out")
"/bin/snakemake")))