summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-14 16:27:39 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-27 08:05:42 -0500
commitdbcd2050500c932190d710cee43f5e14f0fd59db (patch)
treef032a462cea6b423a36408c533a7f8869876f955 /gnu
parentbde77a83243679870907e5d8f8132958a00a7f52 (diff)
downloadguix-patches-dbcd2050500c932190d710cee43f5e14f0fd59db.tar
guix-patches-dbcd2050500c932190d710cee43f5e14f0fd59db.tar.gz
gnu: python-xyz: Move a few modules to (gnu packages python-build).
* gnu/packages/python-xyz.scm (python-pep517): Inherit from python-pep517-bootstrap. Remove the inherited common fields. (python-poetry-core, python-wheel) (python-toml): Move to ... * gnu/packages/python-build.scm: ... here, a new module. (python-pep517-bootstrap): New package. * gnu/local.mk (GNU_SYSTEM_MODULES): Register the new module.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bittorrent.scm1
-rw-r--r--gnu/packages/check.scm1
-rw-r--r--gnu/packages/finance.scm1
-rw-r--r--gnu/packages/machine-learning.scm1
-rw-r--r--gnu/packages/protobuf.scm1
-rw-r--r--gnu/packages/python-build.scm134
-rw-r--r--gnu/packages/python-crypto.scm1
-rw-r--r--gnu/packages/python-web.scm1
-rw-r--r--gnu/packages/python-xyz.scm94
-rw-r--r--gnu/packages/sphinx.scm1
-rw-r--r--gnu/packages/version-control.scm1
-rw-r--r--gnu/packages/virtualization.scm1
13 files changed, 148 insertions, 91 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index c631e449d1..cc9b47b493 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -460,6 +460,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/purescript.scm \
%D%/packages/pv.scm \
%D%/packages/python.scm \
+ %D%/packages/python-build.scm \
%D%/packages/python-check.scm \
%D%/packages/python-compression.scm \
%D%/packages/python-crypto.scm \
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 08e61d7ba2..29b0d62ad2 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -55,6 +55,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index d9a1fb3acf..98b5bb293f 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -67,6 +67,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages time)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 8ead37beb3..1798ad82bc 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -92,6 +92,7 @@
#:use-module (gnu packages popt)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 920b5d82ed..a3084c17e2 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -74,6 +74,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index a414bc6bbb..61dee46d43 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -40,6 +40,7 @@
#:use-module (gnu packages libevent)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages ruby))
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
new file mode 100644
index 0000000000..b0940b67f3
--- /dev/null
+++ b/gnu/packages/python-build.scm
@@ -0,0 +1,134 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages python-build)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system python)
+ #:use-module (guix download)
+ #:use-module (guix packages))
+
+;;; Commentary:
+;;;
+;;; Python packages to build... Python packages. Since they are bound to be
+;;; relied on by many, their dependencies should be kept minimal, and this
+;;; module should not depend on other modules containing Python packages.
+;;;
+;;; Code:
+
+(define-public python-wheel
+ (package
+ (name "python-wheel")
+ (version "0.33.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "wheel" version))
+ (sha256
+ (base32
+ "0ii6f34rvpjg3nmw4bc2h7fhdsy38y1h93hghncfs5akfrldmj8h"))))
+ (build-system python-build-system)
+ (arguments
+ ;; FIXME: The test suite runs "python setup.py bdist_wheel", which in turn
+ ;; fails to find the newly-built bdist_wheel library, even though it is
+ ;; available on PYTHONPATH. What search path is consulted by setup.py?
+ '(#:tests? #f))
+ (home-page "https://bitbucket.org/pypa/wheel/")
+ (synopsis "Format for built Python packages")
+ (description
+ "A wheel is a ZIP-format archive with a specially formatted filename and
+the @code{.whl} extension. It is designed to contain all the files for a PEP
+376 compatible install in a way that is very close to the on-disk format. Many
+packages will be properly installed with only the @code{Unpack} step and the
+unpacked archive preserves enough information to @code{Spread} (copy data and
+scripts to their final locations) at any later time. Wheel files can be
+installed with a newer @code{pip} or with wheel's own command line utility.")
+ (license license:expat)))
+
+(define-public python2-wheel
+ (package-with-python2 python-wheel))
+
+;;; XXX: Not really at home, but this seems the best place to prevent circular
+;;; module dependencies.
+(define-public python-toml
+ (package
+ (name "python-toml")
+ (version "0.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "toml" version))
+ (sha256
+ (base32
+ "03wbqm5cn685cwx2664hjdpz370njl7lf0yal8s0dkp5w4mn2swj"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;no tests suite in release
+ (home-page "https://github.com/uiri/toml")
+ (synopsis "Library for TOML")
+ (description
+ "@code{toml} is a library for parsing and creating Tom's Obvious, Minimal
+Language (TOML) configuration files.")
+ (license license:expat)))
+
+(define-public python-pep517-bootstrap
+ (hidden-package
+ (package
+ (name "python-pep517-bootstrap")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pep517" version))
+ (sha256
+ (base32
+ "0zqidxah03qpnp6zkg3zd1kmd5f79hhdsfmlc0cldaniy80qddxf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;to avoid circular dependencies
+ (propagated-inputs
+ `(("python-toml" ,python-toml)
+ ("python-wheel" ,python-wheel)))
+ (home-page "https://github.com/pypa/pep517")
+ (synopsis "Wrappers to build Python packages using PEP 517 hooks")
+ (description
+ "Wrappers to build Python packages using PEP 517 hooks.")
+ (license license:expat))))
+
+(define-public python-poetry-core
+ (package
+ (name "python-poetry-core")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "poetry-core" version))
+ (sha256
+ (base32 "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python-poetry/poetry-core")
+ (synopsis "Poetry PEP 517 build back-end")
+ (description
+ "The @code{poetry-core} module provides a PEP 517 build back-end
+implementation developed for Poetry. This project is intended to be
+a light weight, fully compliant, self-contained package allowing PEP 517
+compatible build front-ends to build Poetry managed projects.")
+ (license license:expat)))
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 486cc48457..c3ed58c424 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -54,6 +54,7 @@
#:use-module (gnu packages password-utils)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-compression)
#:use-module (gnu packages python-web)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 622f5fc6e2..c8ad94ae49 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -75,6 +75,7 @@
#:use-module (gnu packages libffi)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-compression)
#:use-module (gnu packages python-crypto)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a22d6e865a..4b8e538168 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -164,6 +164,7 @@
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-compression)
#:use-module (gnu packages python-crypto)
@@ -2720,38 +2721,6 @@ with sensible defaults out of the box.")
(base32 "0njsm0wn31l21bi118g5825ma5sa3rwn7v2x4wjd7yiiahkri337"))))
(arguments `())))
-(define-public python-wheel
- (package
- (name "python-wheel")
- (version "0.36.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "wheel" version))
- (sha256
- (base32
- "0pi4w0brz7a86ddk6pm8p6j0w6d7jgacgxm0c2dab3k5cb8yy7p1"))))
- (build-system python-build-system)
- (arguments
- ;; FIXME: The test suite runs "python setup.py bdist_wheel", which in turn
- ;; fails to find the newly-built bdist_wheel library, even though it is
- ;; available on PYTHONPATH. What search path is consulted by setup.py?
- '(#:tests? #f))
- (home-page "https://bitbucket.org/pypa/wheel/")
- (synopsis "Format for built Python packages")
- (description
- "A wheel is a ZIP-format archive with a specially formatted filename and
-the @code{.whl} extension. It is designed to contain all the files for a PEP
-376 compatible install in a way that is very close to the on-disk format. Many
-packages will be properly installed with only the @code{Unpack} step and the
-unpacked archive preserves enough information to @code{Spread} (copy data and
-scripts to their final locations) at any later time. Wheel files can be
-installed with a newer @code{pip} or with wheel's own command line utility.")
- (license license:expat)))
-
-(define-public python2-wheel
- (package-with-python2 python-wheel))
-
(define-public python-vcversioner
(package
(name "python-vcversioner")
@@ -4062,27 +4031,6 @@ which can produce feeds in RSS 2.0, RSS 0.91, and Atom formats.")
(define-public python2-feedgenerator
(package-with-python2 python-feedgenerator))
-(define-public python-toml
- (package
- (name "python-toml")
- (version "0.10.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "toml" version))
- (sha256
- (base32
- "03wbqm5cn685cwx2664hjdpz370njl7lf0yal8s0dkp5w4mn2swj"))))
- (build-system python-build-system)
- (arguments
- `(#:tests? #f)) ;no tests suite in release
- (home-page "https://github.com/uiri/toml")
- (synopsis "Library for TOML")
- (description
- "@code{toml} is a library for parsing and creating Tom's Obvious, Minimal
-Language (TOML) configuration files.")
- (license license:expat)))
-
(define-public python-jsonrpc-server
(package
(name "python-jsonrpc-server")
@@ -8308,16 +8256,8 @@ PEP 8.")
(define-public python-pep517
(package
+ (inherit python-pep517-bootstrap)
(name "python-pep517")
- (version "0.9.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pep517" version))
- (sha256
- (base32
- "0zqidxah03qpnp6zkg3zd1kmd5f79hhdsfmlc0cldaniy80qddxf"))))
- (build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
@@ -8333,15 +8273,7 @@ PEP 8.")
`(("python-mock" ,python-mock)
("python-pytest" ,python-pytest)
("python-testpath" ,python-testpath)))
- (propagated-inputs
- `(("python-toml" ,python-toml)
- ("python-wheel" ,python-wheel)))
- (home-page "https://github.com/pypa/pep517")
- (synopsis "Wrappers to build Python packages using PEP 517 hooks")
- (description
- "Wrappers to build Python packages using PEP 517 hooks.")
- (properties `((python2-variant . ,(delay python2-pep517))))
- (license license:expat)))
+ (properties `((python2-variant . ,(delay python2-pep517))))))
;; Skip the tests so we don't create a cyclical dependency with pytest.
(define-public python2-pep517
@@ -13222,26 +13154,6 @@ powerful API: thread-safety; decorator syntax; support for memcached, redis,
database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
(license license:expat)))
-(define-public python-poetry-core
- (package
- (name "python-poetry-core")
- (version "1.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "poetry-core" version))
- (sha256
- (base32 "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))
- (build-system python-build-system)
- (home-page "https://github.com/python-poetry/poetry-core")
- (synopsis "Poetry PEP 517 build back-end")
- (description
- "The @code{poetry-core} module provides a PEP 517 build back-end
-implementation developed for Poetry. This project is intended to be
-a light weight, fully compliant, self-contained package allowing PEP 517
-compatible build front-ends to build Poetry managed projects.")
- (license license:expat)))
-
(define-public poetry
(package
(name "poetry")
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 3531ed3bdf..e666456e4a 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -42,6 +42,7 @@
#:use-module (gnu packages graphviz)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages time))
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 752f06dc7b..afbae86772 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -98,6 +98,7 @@
#:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 2262aa6197..8da57cf6ab 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -87,6 +87,7 @@
#:use-module (gnu packages polkit)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)