summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-06 12:31:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:31 +0200
commitd851f8d7b9cc4bad89bff9dfbf6024f7112a273d (patch)
treee64c6bd4df4e931df6f293afb199b9add40e3f2a /gnu
parentb8fe63bb51d1da2232b37b33b26733b8ead3e968 (diff)
downloadguix-patches-d851f8d7b9cc4bad89bff9dfbf6024f7112a273d.tar
guix-patches-d851f8d7b9cc4bad89bff9dfbf6024f7112a273d.tar.gz
gnu: Add texlive-currfile.
* gnu/packages/tex.scm (texlive-currfile): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a11c13ab26..0ad2581996 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5486,6 +5486,37 @@ definition, or to define space-stripped macros.")
(define-deprecated-package texlive-latex-trimspaces texlive-trimspaces)
+(define-public texlive-currfile
+ (package
+ (name "texlive-currfile")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/currfile/" "source/latex/currfile/"
+ "tex/latex/currfile/")
+ (base32
+ "1l9win5msf80yzgzfx580d1hw8lza1advhqkhpz83i080020asji")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs
+ (list texlive-ydoc))
+ (propagated-inputs
+ (list texlive-filehook
+ texlive-kvoptions))
+ (home-page "https://ctan.org/pkg/currfile")
+ (synopsis "Provide file name and path of input files")
+ (description
+ "The package provides macros holding file name information (directory,
+base name, extension, full name and full path) for files read by LaTeX
+@code{\\input} and @code{\\include} macros; it uses the file hooks provided by
+the author's @code{filehook}. In particular, it restores the parent file name
+after the trailing @code{\\clearpage} of an @code{\\included} file; as
+a result, the macros may be usefully employed in the page header and footer of
+the last printed page of such a file. The depth of inclusion is made
+available, together with the parent (including file) and parents (all
+including files to the root of the tree). The package supersedes FiNK.")
+ (license license:lppl1.3+)))
+
(define-public texlive-calrsfs
(package
(inherit