summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 00:22:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:38 +0200
commitd8418675b03e8fa3c4e2d5926efb3da6c3769bb3 (patch)
treeea428ac4369ffbd342eabbed957b9f7dc7b744aa /gnu
parent4270d94ee36775b88765bc322af7f7c1a514f125 (diff)
downloadguix-patches-d8418675b03e8fa3c4e2d5926efb3da6c3769bb3.tar
guix-patches-d8418675b03e8fa3c4e2d5926efb3da6c3769bb3.tar.gz
gnu: texlive-latex-ifplatform -> texlive-ifplatform.
* gnu/packages/tex.scm (texlive-ifplatform): New variable. (texlive-latex-ifplatform): Deprecate variable. (texlive-pstool): (texlive-minted): Use new name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm49
1 files changed, 28 insertions, 21 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0818461101..91cf368cc7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5318,31 +5318,38 @@ not yet reflected in the package's or class's code. The file
meant to be loaded during format generation and not by the user.")
(license license:lppl1.3c))))
-(define-public texlive-latex-ifplatform
+(define-public texlive-ifplatform
(package
- (name "texlive-latex-ifplatform")
+ (name "texlive-ifplatform")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "ifplatform"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "157pplavvm2z97b3jl4x41w11k6q9wgy074mfg0dwmsx5lm328jy"))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ifplatform/"
+ "source/latex/ifplatform/"
+ "tex/latex/ifplatform/")
+ (base32
+ "1llas0xwq3y9nk7gblg40l99cgmkl9r7rbfazrhpnbaz5cshl8pl")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
- (propagated-inputs (list texlive-catchfile))
- (arguments '(#:tex-directory "latex/ifplatform"))
- (home-page "https://www.ctan.org/pkg/ifplatform")
+ (propagated-inputs
+ (list texlive-catchfile
+ texlive-iftex
+ texlive-pdftexcmds
+ texlive-tools))
+ (home-page "https://ctan.org/pkg/ifplatform")
(synopsis "Conditionals to test which platform is being used")
(description
- "This package uses the (La)TeX extension @code{-shell-escape} to
-establish whether the document is being processed on a Windows or on a
-Unix-like system, or on Cygwin (Unix environment over a Windows system).
+ "This package uses the (La)TeX extension @samp{-shell-escape} to
+establish whether the document is being processed on a Windows or on
+a Unix-like system, or on Cygwin.
+
Booleans provided are: @code{\\ifwindows}, @code{\\iflinux}, @code{\\ifmacosx}
-and @code{\\ifcygwin}. The package also preserves the output of @code{uname}
-on a Unix-like system, which may be used to distinguish between various
-classes of systems.")
- (license license:lppl)))
+and @code{\\ifcygwin}. The package also preserves the output of
+@command{uname} on a Unix-like system, which may be used to distinguish
+between various classes of Unix systems.")
+ (license license:lppl1.3c)))
+
+(define-deprecated-package texlive-latex-ifplatform texlive-ifplatform)
(define-public texlive-latex-natbib
(package
@@ -5467,7 +5474,7 @@ rotated.")
(list texlive-bigfoot ; for suffix
texlive-filemod
texlive-graphics
- texlive-latex-ifplatform
+ texlive-ifplatform
texlive-l3kernel ; for expl3
texlive-oberdiek
texlive-latex-psfrag
@@ -10663,7 +10670,7 @@ configuration of its own fixed names, using @file{.mld} files.")
texlive-fvextra
texlive-latex-float
texlive-latex-framed
- texlive-latex-ifplatform
+ texlive-ifplatform
texlive-latex-newfloat
texlive-lineno
texlive-xstring))