summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 21:24:53 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:39 -0500
commitd7d143e5537ec131f0b10c47bb66ffca16408e0d (patch)
tree6e99006b16dbdbc758f772ade3a3aca196b9188b /gnu
parent132e107480fe3f71e3874d59f016bb2ca328475c (diff)
downloadguix-patches-d7d143e5537ec131f0b10c47bb66ffca16408e0d.tar
guix-patches-d7d143e5537ec131f0b10c47bb66ffca16408e0d.tar.gz
gnu: ghc-edit-distance: Update dependency constraints.
* gnu/packages/haskell-xyz.scm (ghc-edit-distance): Change the phase that updates the Cabal file to allow for newer versions of 'QuickCheck'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index df032e5437..d206231cdd 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2964,7 +2964,7 @@ with various performance characteristics.")
(lambda _
(substitute* "edit-distance.cabal"
(("QuickCheck >= 2\\.4 && <2\\.9")
- "QuickCheck >= 2.4 && < 2.12")))))))
+ "QuickCheck >= 2.4 && < 2.14")))))))
(inputs
`(("ghc-random" ,ghc-random)
("ghc-test-framework" ,ghc-test-framework)