summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-23 12:18:00 +0000
committerLeo Famulari <leo@famulari.name>2021-10-23 16:22:06 -0400
commitd71336b2e3c86432f174645163d06a3ef83deaae (patch)
tree34756dbad842cd19781a513fc6f4be7e8ac0d14a /gnu
parentae3fa855f38bd3952e2cf510bbb58bbe74aeb3f8 (diff)
downloadguix-patches-d71336b2e3c86432f174645163d06a3ef83deaae.tar
guix-patches-d71336b2e3c86432f174645163d06a3ef83deaae.tar.gz
gnu: Rename openexr to openexr-2.
This is done so the OpenEXR package can be upgraded to version 3 in a later commit. * gnu/packages/graphics.scm (openexr): Rename to ... (openexr-2): ... new variable. (blender, blender-2.79, openimageio, povray)[inputs]: Adjust accordingly. (ctl)[propagated-inputs]: Likewise. * gnu/packages/animation.scm (synfig)[propagated-inputs]: Likewise. * gnu/packages/gimp.scm (gegl, gimp)[inputs]: Likewise. * gnu/packages/gstreamer.scm (gst-plugins-bad)[inputs]: Likewise. * gnu/packages/image-processing.scm (mia, opencolorio, opencv, vips, gmic, nip2)[inputs]: Likewise. * gnu/packages/image-viewers.scm (luminance-hdr)[inputs]: Likewise. * gnu/packages/image.scm (freeimage, vigra, devil)[inputs]: Likewise. * gnu/packages/kde-frameworks.scm (kimageformats)[inputs]: Likewise. * gnu/packages/kde.scm (krita)[inputs]: Likewise. * gnu/packages/photo.scm (enblend-enfuse, darktable, hugin)[inputs]: Likewise. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/animation.scm2
-rw-r--r--gnu/packages/gimp.scm4
-rw-r--r--gnu/packages/graphics.scm12
-rw-r--r--gnu/packages/gstreamer.scm2
-rw-r--r--gnu/packages/image-processing.scm12
-rw-r--r--gnu/packages/image-viewers.scm2
-rw-r--r--gnu/packages/image.scm6
-rw-r--r--gnu/packages/kde-frameworks.scm2
-rw-r--r--gnu/packages/kde.scm2
-rw-r--r--gnu/packages/photo.scm6
10 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 6f116af63c..a8ead4295c 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -179,7 +179,7 @@ C++ @dfn{Standard Template Library} (STL).")
("libxml++" ,libxml++)
("libsigc++" ,libsigc++)
("mlt" ,mlt-6)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("pango" ,pango)))
(native-inputs
`(("intltool" ,intltool)
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index ae59385d45..11ec47b7e5 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -265,7 +265,7 @@ provided, as well as a framework to add new color models and data types.")
("libtiff" ,libtiff)
("libwebp" ,libwebp)
("maxflow" ,maxflow)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("pango" ,pango)
("poppler" ,poppler)
("sdl2" ,sdl2)))
@@ -352,7 +352,7 @@ buffers.")
("libmng" ,libmng) ; optional, MNG support
("librsvg" ,librsvg) ; optional, SVG support
("libxcursor" ,libxcursor) ; optional, Mouse Cursor support
- ("openexr" ,openexr) ; optional, EXR support
+ ("openexr" ,openexr-2) ; optional, EXR support
("openjpeg" ,openjpeg) ; optional, JPEG 2000 support
("poppler" ,poppler) ; optional, PDF support
("poppler-data" ,poppler-data) ; optional, PDF support
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index c285d781fe..eda8744bca 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -569,7 +569,7 @@ typically encountered in feature film production.")
("libxrender" ,libxrender)
("opencolorio" ,opencolorio)
("openimageio" ,openimageio)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("opensubdiv" ,opensubdiv)
("ilmbase" ,ilmbase)
("openjpeg" ,openjpeg)
@@ -669,7 +669,7 @@ application can be customized via its API for Python scripting.")
("libx11" ,libx11)
("opencolorio" ,opencolorio)
("openimageio" ,openimageio)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("ilmbase" ,ilmbase)
("openjpeg" ,openjpeg)
("libjpeg" ,libjpeg-turbo)
@@ -1105,7 +1105,7 @@ graphics.")
(home-page "https://www.ogre3d.org/")
(license license:expat)))
-(define-public openexr
+(define-public openexr-2
(package
(name "openexr")
(version (package-version ilmbase))
@@ -1189,7 +1189,7 @@ storage of the \"EXR\" file format for storing 16-bit floating-point images.")
("libjpeg" ,libjpeg-turbo)
("libtiff" ,libtiff)
("giflib" ,giflib)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("ilmbase" ,ilmbase)
("pugixml" ,pugixml)
("python" ,python-wrapper)
@@ -1392,7 +1392,7 @@ in Julia).")
("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("libtiff" ,libtiff)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("sdl" ,sdl)
("zlib" ,zlib)))
(arguments
@@ -1513,7 +1513,7 @@ and is connected to the programming logic using data bindings and commands.")
(arguments '(#:tests? #f)) ;no 'test' target
;; Headers include OpenEXR and IlmBase headers.
- (propagated-inputs `(("openexr" ,openexr)))
+ (propagated-inputs `(("openexr" ,openexr-2)))
(home-page "http://ampasctl.sourceforge.net")
(synopsis "Color Transformation Language")
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 73ae2c9815..bb991789da 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -768,7 +768,7 @@ model to base your own plug-in on, here it is.")
("mesa" ,mesa)
("neon" ,neon)
("openal" ,openal)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("openjpeg" ,openjpeg)
("openssl" ,openssl)
("opus" ,opus)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 403763d94f..00b4a3c151 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -162,7 +162,7 @@ licences similar to the Modified BSD licence."))))
("maxflow" ,maxflow)
("niftilib" ,niftilib)
("nlopt" ,nlopt)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("python-lxml" ,python2-lxml)
("vtk" ,vtk)))
(native-inputs
@@ -232,7 +232,7 @@ of external libraries that provide additional functionality.")
;; ocioconvert fails: error: conflicting declaration ?typedef void
;; (* PFNGLGETFRAGMENTMATERIALFVSGIXPROC)(GLenum, GLenum, GLfloat*)
`(("lcms" ,lcms)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("tinyxml" ,tinyxml)))
(home-page "https://opencolorio.org")
(synopsis "Color management for visual effects and animation")
@@ -637,7 +637,7 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
("libwebp" ,libwebp)
("zlib" ,zlib)
("gtkglext" ,gtkglext)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("ilmbase" ,ilmbase)
("gtk+" ,gtk+-2)
("python-numpy" ,python-numpy)
@@ -703,7 +703,7 @@ vision algorithms. It can be used to do things like:
("libwebp" ,libwebp)
("matio" ,matio)
("niftilib" ,niftilib)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("orc" ,orc)
("pango" ,pango)
("poppler" ,poppler)))
@@ -755,7 +755,7 @@ due to its architecture which automatically parallelises the image workflows.")
("libtiff" ,libtiff)
("libx11" ,libx11)
;;("opencv" ,opencv) ;OpenCV is currently broken in the CI
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("zlib" ,zlib)))
(home-page "https://gmic.eu/")
(synopsis "Full-featured framework for digital image processing")
@@ -861,7 +861,7 @@ including 2D color images.")
("matio" ,matio)
("lcms" ,lcms)
("libwebp" ,libwebp)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("poppler" ,poppler)
("gsl" ,gsl)))
(native-inputs
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 0bd53aae8f..4f87b63ca1 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -544,7 +544,7 @@ It supports JPEG, PNG and GIF formats.")
("libpng" ,libpng)
("libjpeg" ,libjpeg-turbo)
("lcms" ,lcms)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("fftw" ,fftwf)
("gsl" ,gsl)
("libtiff" ,libtiff)))
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 09277514aa..fc021dd2db 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1158,7 +1158,7 @@ supplies a generic doubly-linked list and some string functions.")
("libraw" ,libraw)
("libtiff" ,libtiff)
("libwebp" ,libwebp)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("openjpeg" ,openjpeg)
("zlib" ,zlib)))
(synopsis "Library for handling popular graphics image formats")
@@ -1192,7 +1192,7 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("libtiff" ,libtiff)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("python" ,python-wrapper)
("python-numpy" ,python-numpy)
("zlib" ,zlib)))
@@ -1412,7 +1412,7 @@ and XMP metadata of images in various formats.")
("libmng" ,libmng)
("libpng" ,libpng)
("libtiff" ,libtiff)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("zlib" ,zlib)))
(synopsis "Library for manipulating many image formats")
(description "Developer's Image Library (DevIL) is a library to develop
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 00d5eb049d..6a48dc229a 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1816,7 +1816,7 @@ by applications to write metadata.")
("pkg-config" ,pkg-config)))
(inputs
`(("karchive" ,karchive) ; for Krita and OpenRaster images
- ("openexr" ,openexr) ; for OpenEXR high dynamic-range images
+ ("openexr" ,openexr-2) ; for OpenEXR high dynamic-range images
("qtbase" ,qtbase-5)))
(arguments
`(#:phases
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 6cba017af0..c6f5227e8b 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -522,7 +522,7 @@ illustrate project schedules.")
("libx11" ,libx11)
("libxcb" ,libxcb)
("libxi" ,libxi)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("perl" ,perl)
("poppler-qt5" ,poppler-qt5)
("qtbase" ,qtbase-5)
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 908a872b6b..6364323731 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -413,7 +413,7 @@ overlapping images, as well as some command line tools.")
("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("libtiff" ,libtiff)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("vigra" ,vigra)
("zlib" ,zlib)))
(arguments
@@ -568,7 +568,7 @@ photographic equipment.")
("libxslt" ,libxslt)
("lua" ,lua) ;optional, for plugins
("opencl-icd-loader" ,opencl-icd-loader) ;optional, for OpenCL support
- ("openexr" ,openexr) ;optional, for EXR import/export
+ ("openexr" ,openexr-2) ;optional, for EXR import/export
("openjpeg" ,openjpeg) ;optional, for JPEG2000 export
("osm-gps-map" ,osm-gps-map) ;optional, for geotagging view
("pugixml" ,pugixml)
@@ -726,7 +726,7 @@ off' shooting directly from the controlling computer.")
("libxi" ,libxi)
("libxmu" ,libxmu)
("mesa" ,mesa)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("sqlite" ,sqlite)
("vigra" ,vigra)
("wxwidgets" ,wxwidgets)