summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-22 23:55:16 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:45 +0100
commitd6973ec9798529fbac30de884ce328dd0fd60b82 (patch)
tree2829f33ef276d5b81ae73a8bee42e9f18f0e90b5 /gnu
parentcc1cca9ffbda61d5b6ce4f7bbe23e3c5efee0b3b (diff)
downloadguix-patches-d6973ec9798529fbac30de884ce328dd0fd60b82.tar
guix-patches-d6973ec9798529fbac30de884ce328dd0fd60b82.tar.gz
gnu: Add knetwalk.
* gnu/packages/games.scm (knetwalk): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4968a860b0..fac79f98d1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8680,3 +8680,46 @@ player shoots rays into the grid to deduce the positions of hidden objects.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public knetwalk
+ (package
+ (name "knetwalk")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/knetwalk-" version ".tar.xz"))
+ (sha256
+ (base32 "1i340salzgqdw8y33wrrydmpgx3pvwf5wrbljlh67cjf6s4csx7d"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Turn the board pieces to get all computers connected")
+ (description "KNetWalk is a small game where you have to build up a
+computer network by rotating the wires to connect the terminals to the server.
+When the network is build, a highscore-list comes up where competitions can be
+fought out.
+
+KNetwalk is a puzzle game where the player arranges sections of wire to
+connect all the computers on the board.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))