summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-20 09:33:28 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:41 +0100
commitd6931b3300d5867b22e04f01aca0cdef2ca081b1 (patch)
tree1f05a77eefba47b2846e8661b20a6fd949e14024 /gnu
parentdcfdd70d538d9bb7f82ce2ea1a93d8206d54a4b6 (diff)
downloadguix-patches-d6931b3300d5867b22e04f01aca0cdef2ca081b1.tar
guix-patches-d6931b3300d5867b22e04f01aca0cdef2ca081b1.tar.gz
gnu: matterbridge: Swap to go-build-system.
* gnu/packages/messaging.scm (matterbridge): Adjust package style. [build-system]: Swap to go-build-system. [arguments]: <#:go>: Use go-1.21. Change-Id: I839f1a0c369a143e8d36d6f919e1751a915c524a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm36
1 files changed, 4 insertions, 32 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index e14536b957..9c62dac07c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3300,39 +3300,11 @@ designed for experienced users.")
(sha256
(base32
"0939fiy7z53izznfhlr7c6vaskbmkbj3ncb09fzx5dmz9cjngy80"))))
- ;; Using the go-build-system results in the same error message
- ;; than in the bug 1551[1]. So we fix it by running go build
- ;; manually in the git repository as-is as this is the solution
- ;; given to that bug by the matterbridge developers.
- ;; [1]https://github.com/42wim/matterbridge/issues/1551
- (build-system gnu-build-system)
+ (build-system go-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (delete 'configure)
- (replace 'build
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "GOCACHE"
- (string-append (getcwd) "/go-build"))
- (setenv "GOBIN"
- (string-append (assoc-ref outputs "out") "/bin"))
- (invoke "go" "build" "-v" "-x")))
- (replace 'check
- (lambda* (#:key outputs tests? #:allow-other-keys)
- (when tests?
- (setenv "GOCACHE"
- (string-append (getcwd) "/go-build"))
- (setenv "GOBIN"
- (string-append (assoc-ref outputs "out")
- "/bin"))
- (invoke "go" "test" "-v" "-x"))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "GOCACHE"
- (string-append (getcwd) "/go-build"))
- (setenv "GOBIN"
- (string-append (assoc-ref outputs "out") "/bin"))
- (invoke "go" "install" "-v" "-x"))))))
- (native-inputs (list go))
+ (list
+ #:go go-1.21
+ #:import-path "github.com/42wim/matterbridge"))
(synopsis "Bridge together various messaging networks and protocols")
(description
"Relays messages between different channels from various