summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKristian Lein-Mathisen <kristianlein@gmail.com>2022-11-02 20:36:51 +0100
committerChristopher Baines <mail@cbaines.net>2022-11-07 20:32:32 +0100
commitd60c9fbf95409a72013d8368e6f50c1ac055df5a (patch)
tree5798bdfd78082cd15b35e2d6da5ba0b479dcf668 /gnu
parentcad335a32acf8c31b49fe83f1b38b1d1a6da76be (diff)
downloadguix-patches-d60c9fbf95409a72013d8368e6f50c1ac055df5a.tar
guix-patches-d60c9fbf95409a72013d8368e6f50c1ac055df5a.tar.gz
gnu: Add avr-gdb.
* gnu/packages/gdb.scm (avr-gdb): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gdb.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 7d8416c7c5..fd0bc80e44 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -171,3 +171,24 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
(name "gdb-minimal")
(inputs (fold alist-delete (package-inputs gdb)
'("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
+
+(define-public avr-gdb
+ (package/inherit gdb-12
+ (name "avr-gdb")
+ (arguments
+ `(#:configure-flags
+ (list "--target=avr"
+ "--disable-nls"
+ "--enable-languages=c,c++"
+ "--with-system-readline"
+ "--enable-source-highlight")
+ ,@(package-arguments gdb-12)))
+ (synopsis "The GNU Debugger for AVR")
+ (description
+ "GDB is the GNU debugger. With it, you can monitor what a program is
+doing while it runs or what it was doing just before a crash. It allows you
+to specify the runtime conditions, to define breakpoints, and to change how
+the program is running to try to fix bugs.
+
+This variant of GDB can be used to debug programs written for the AVR
+microcontroller architecture.")))