summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEthan R. Jones <doubleplusgood23@gmail.com>2017-05-27 11:42:46 -0400
committerLudovic Courtès <ludo@gnu.org>2017-05-31 17:08:45 +0200
commitd5fa27774ce812c28370490417d446bc2f5b423e (patch)
tree9f89c7d4fcefa805a282da1c517c0394e2160784 /gnu
parente0c407074ea0d55d7a675d48ea68de72e11d4fc1 (diff)
downloadguix-patches-d5fa27774ce812c28370490417d446bc2f5b423e.tar
guix-patches-d5fa27774ce812c28370490417d446bc2f5b423e.tar.gz
gnu: Add mediainfo.
* gnu/packages/video.scm (mediainfo): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index cacf41895c..ac2eec5f94 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2114,3 +2114,42 @@ MPEG-2, MPEG-4, DVD (VOB)...
@end itemize\n")
(license license:bsd-2)))
+;; TODO also have a GUI version available
+(define-public mediainfo
+ (package
+ (name "mediainfo")
+ (version "0.7.95")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://mediaarea.net/download/source/"
+ name "/" version "/"
+ name "_" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0dy51a3i79jppmg1gi4f6h7jx4hcgnkmfim4d7d3gmnlbkjh8anv"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("zlib" ,zlib)
+ ("libmediainfo", libmediainfo)
+ ("libzen" ,libzen)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; lacks tests
+ #:phases
+ ;; build scripts not in root of archive
+ (modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda _
+ (chdir "Project/GNU/CLI")))
+ (add-before 'configure 'autogen
+ (lambda _
+ (zero? (system* "./autogen.sh")))))))
+ (home-page "https://mediaarea.net/en/MediaInfo")
+ (synopsis "Utility for reading media metadata")
+ (description "MediaInfo is a utility used for retrieving technical
+information and other metadata about audio or video files. It supports the
+many codecs and formats supported by libmediainfo.")
+ (license license:bsd-2)))