summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-31 20:56:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:30 -0500
commitd396897795cbea08ae5a13146eff15eb1b6eb88f (patch)
treef11e75c2bb164c5238046fc0ca29ed77608146b9 /gnu
parent9b54d521160f5798faea0fe70e280ce5ec5e6c4c (diff)
downloadguix-patches-d396897795cbea08ae5a13146eff15eb1b6eb88f.tar
guix-patches-d396897795cbea08ae5a13146eff15eb1b6eb88f.tar.gz
gnu: python-docker: Update to 5.0.3 and remove obsolete package variants.
* gnu/packages/docker.scm (python-docker): Update to 5.0.3. * gnu/packages/python-web.scm (python-requests-2.20): Delete unused package variant. (python-urllib3-1.24): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/docker.scm8
-rw-r--r--gnu/packages/python-web.scm27
2 files changed, 4 insertions, 31 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 8bac1b89ce..c64760fe7b 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -57,21 +57,21 @@
(define-public python-docker
(package
(name "python-docker")
- (version "3.7.3")
+ (version "5.0.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "docker" version))
(sha256
(base32
- "0qmrcvpaz37p85hfddsd4yc8hgqlkzs4cz09q9wmy0pz5pwajqm0"))))
+ "1yr7w8vmdis01myx26pqx7wcyz2cy1mfs421alppq3lpc9ms45nr"))))
(build-system python-build-system)
;; TODO: Tests require a running Docker daemon.
(arguments '(#:tests? #f))
(inputs
- `(("python-requests" ,python-requests-2.20)
+ `(("python-requests" ,python-requests)
("python-six" ,python-six)
- ("python-urllib3" ,python-urllib3-1.24)))
+ ("python-urllib3" ,python-urllib3)))
(propagated-inputs
`(("python-docker-pycreds" ,python-docker-pycreds)
("python-paramiko" ,python-paramiko) ;adds SSH support
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6a08b0a4b4..757b06f0a0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2542,22 +2542,6 @@ APIs.")
than Python’s urllib2 library.")
(license license:asl2.0)))
-;; Some software requires an older version of Requests, notably Docker/Docker
-;; Compose.
-(define-public python-requests-2.20
- (package (inherit python-requests)
- (version "2.20.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "requests" version))
- (sha256
- (base32
- "0qzj6cgv3k9wyj7wlxgz7xq0cfg4jbbkfm24pp8dnhczwl31527a"))))
- (propagated-inputs
- `(("python-urllib3" ,python-urllib3-1.24)
- ("python-idna" ,python-idna-2.7)
- ,@(package-propagated-inputs python-requests)))))
-
(define-public python2-requests
(package-with-python2 python-requests))
@@ -2824,17 +2808,6 @@ supports url redirection and retries, and also gzip and deflate decoding.")
(properties `((python2-variant . ,(delay python2-urllib3))))
(license license:expat)))
-;; Some software requires an older version of urllib3, notably Docker.
-(define-public python-urllib3-1.24
- (package (inherit python-urllib3)
- (version "1.24.3")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "urllib3" version))
- (sha256
- (base32
- "1x0slqrv6kixkbcdnxbglvjliwhc1payavxjvk8fvbqjrnasd4r3"))))))
-
(define-public python2-urllib3
(let ((base (package-with-python2 (strip-python2-variant python-urllib3))))
(package/inherit