summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-11-05 19:47:07 +0300
committerLudovic Courtès <ludo@gnu.org>2022-11-07 22:49:51 +0100
commitd178c89a2ad5a92cf967030ce0059f003417ad52 (patch)
treeab2de754e7122d4938920a3b7243e83322b2f71d /gnu
parent8ab84fea6f0522dfe510e4ff94ac19fb6ba625a2 (diff)
downloadguix-patches-d178c89a2ad5a92cf967030ce0059f003417ad52.tar
guix-patches-d178c89a2ad5a92cf967030ce0059f003417ad52.tar.gz
gnu: Add guile-png.
* gnu/packages/guile-xyz.scm (guile-png): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 38a0b3e4cb..71bbba7fbe 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3542,6 +3542,34 @@ in C using Gtk+-3 and WebKitGtk.")
perform geometrical transforms on JPEG images.")
(license license:gpl3+))))
+(define-public guile-png
+ (package
+ (name "guile-png")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-png")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0ig58zjw60jg4bb4fzm22dqr5zksqpzimpfa8wcarv8gjp861cw5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+ (native-inputs (list autoconf automake pkg-config texinfo))
+ (inputs (list bash-minimal guile-3.0 guile-lib guile-zlib))
+ (propagated-inputs (list guile-smc))
+ (home-page "https://github.com/artyom-poptsov/guile-png")
+ (synopsis "PNG file parsing library for Guile")
+ (description
+ "@code{guile-png} is a GNU Guile library for working with the
+@url{https://en.wikipedia.org/wiki/PNG, PNG format}. This library provides
+API for reading and writing PNG data, as well as some basic image processing
+filters.")
+ (license license:gpl3+)))
+
(define-public nomad
(package
(name "nomad")