summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-08-10 00:18:36 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-10 00:18:36 +0200
commitd156c999d0e7413696064992bb4a001d2d95317d (patch)
treea525ac1e71ef638ad5b1819feb151665be7cda97 /gnu
parentcc294bcee6bfaa4524ac43450e41f083539f9cb1 (diff)
parent4c6c683862579b9f1fa6782b9482054eb1059225 (diff)
downloadguix-patches-d156c999d0e7413696064992bb4a001d2d95317d.tar
guix-patches-d156c999d0e7413696064992bb4a001d2d95317d.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm4
-rw-r--r--gnu/packages/curl.scm28
-rw-r--r--gnu/packages/samba.scm4
3 files changed, 32 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index a9cb2a52ac..a7e79da3ff 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1599,14 +1599,14 @@ done with the @code{auditctl} utility.")
(define-public nmap
(package
(name "nmap")
- (version "7.50")
+ (version "7.60")
(source (origin
(method url-fetch)
(uri (string-append "https://nmap.org/dist/nmap-" version
".tar.bz2"))
(sha256
(base32
- "1ckl2qxqxkrfa2qxdrqyaa4k1hhj273aqckrc46fijdz0a76mag9"))
+ "08bga42ipymmbxd7wy4x5sl26c0ir1fm3n9rc6nqmhx69z66wyd8"))
(modules '((guix build utils)))
(snippet
'(map delete-file-recursively
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index af15aa38c4..492a049a05 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
@@ -40,6 +42,7 @@
(define-public curl
(package
(name "curl")
+ (replacement curl-7.55.0)
(version "7.54.1")
(source (origin
(method url-fetch)
@@ -119,3 +122,28 @@ tunneling, and so on.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))
(home-page "https://curl.haxx.se/")))
+
+(define-public curl-7.55.0
+ (package
+ (inherit curl)
+ (version "7.55.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://curl.haxx.se/download/curl-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1785vxi0jamiv9d1wr1l45g0fm9ircxdfyfzf7ld8zv0z0i8bmfd"))))
+ (arguments
+ `(,@(substitute-keyword-arguments (package-arguments curl)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'install 'fix-Makefile
+ ;; Fix a regression in 7.55.0 where docs are not installed.
+ ;; https://github.com/curl/curl/commit/a7bbbb7c368c6096802007f61f19a02e9d75285b
+ (lambda _
+ (substitute* "Makefile"
+ (("install-data-hook:\n")
+ "install-data-hook:\n\tcd docs/libcurl && $(MAKE) install\n"))
+ #t)))))))))
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 4a7880cfe5..116d7f60ec 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -149,14 +149,14 @@ anywhere.")
(define-public samba
(package
(name "samba")
- (version "4.6.6")
+ (version "4.6.7")
(source (origin
(method url-fetch)
(uri (string-append "https://download.samba.org/pub/samba/stable/"
"samba-" version ".tar.gz"))
(sha256
(base32
- "13hs7xplygbl5dgwnn3l0hkbc0a282wdrkbx5c7y6nnqyw4whcgw"))))
+ "1ynxndfk45zkkylz3jsrx42a7kmm42jddk5bdhihyf88vs9l7wly"))))
(build-system gnu-build-system)
(arguments
'(#:phases