summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2021-06-01 20:22:52 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-06-06 17:16:35 +0200
commitcfa65d777071675ca66d59b32f34c4f79a6b16e1 (patch)
tree578804cc71edbb66defd2a055e48a74a9c80579e /gnu
parent8f5aa879de8d9d94c9c590e2ac128f84b53beac8 (diff)
downloadguix-patches-cfa65d777071675ca66d59b32f34c4f79a6b16e1.tar
guix-patches-cfa65d777071675ca66d59b32f34c4f79a6b16e1.tar.gz
gnu: Add ocaml-compiler-libs.
* gnu/packages/ocaml.scm (ocaml-compiler-libs): New variable. (ocaml4.07-compiler-libs): Inherit from ocaml-compiler-libs. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm42
1 files changed, 29 insertions, 13 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index dbb34cbe78..08b62278d1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4083,7 +4083,7 @@ syntax checking on dedukti files.")
`(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
("ocaml-migrate-parsetree"
,(package-with-ocaml4.07 ocaml-migrate-parsetree))
- ("ocaml-compiler-libs" ,ocaml4.07-compiler-libs)
+ ("ocaml-compiler-libs" ,(package-with-ocaml4.07 ocaml-compiler-libs))
("ocaml-sexplib0" ,(package-with-ocaml4.07 ocaml-sexplib0))
("ocaml-stdio" ,(package-with-ocaml4.07 ocaml-stdio))
("ocaml-ppxlib" ,ocaml4.07-ppxlib)))
@@ -4685,34 +4685,50 @@ provided by companion libraries such as
#:dune ,ocaml4.07-dune))
(properties '()))))
-(define-public ocaml4.07-compiler-libs
+(define-public ocaml-compiler-libs
(package
- (name "ocaml4.07-compiler-libs")
- (version "0.11.0")
+ (name "ocaml-compiler-libs")
+ (version "0.12.3")
(home-page "https://github.com/janestreet/ocaml-compiler-libs")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url (string-append home-page ".git"))
+ (url home-page)
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "03jds7bszh8wwpfwxb3dg0gyr1j1872wxwx1xqhry5ir0i84bg0s"))))
+ "00nrar7h2pyflbdiq6wwwrb4k5jh9iff0jllihzm6ms8d5pspsg5"))))
(build-system dune-build-system)
- (arguments
- `(#:tests? #f ;no tests
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
- (properties `((upstream-name . "ocaml-compiler-libs")))
+ (arguments `(#:tests? #f)) ;no tests
+ (properties `((upstream-name . "ocaml-compiler-libs")
+ (ocaml4.07-variant . ,(delay ocaml4.07-compiler-libs))))
(synopsis "Compiler libraries repackaged")
(description "This package simply repackages the OCaml compiler libraries
so they don't expose everything at toplevel. For instance, @code{Ast_helper}
is now @code{Ocaml_common.Ast_helper}.")
(license license:expat)))
+(define-public ocaml4.07-compiler-libs
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-compiler-libs)
+ (name "ocaml-compiler-libs")
+ (version "0.11.0")
+ (home-page "https://github.com/janestreet/ocaml-compiler-libs")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03jds7bszh8wwpfwxb3dg0gyr1j1872wxwx1xqhry5ir0i84bg0s"))))
+ (properties `((upstream-name . "ocaml-compiler-libs"))))))
+
(define-public ocaml-stdio
(package
(name "ocaml-stdio")
@@ -4789,7 +4805,7 @@ as part of the same ocaml-migrate-parsetree driver.")
(build-system dune-build-system)
(propagated-inputs
`(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
- ("ocaml-compiler-libs" ,ocaml4.07-compiler-libs)
+ ("ocaml-compiler-libs" ,(package-with-ocaml4.07 ocaml-compiler-libs))
("ocaml-migrate-parsetree"
,(package-with-ocaml4.07 ocaml-migrate-parsetree))
("ocaml-ppx-derivers" ,(package-with-ocaml4.07 ocaml-ppx-derivers))