summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-01-13 00:29:23 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-01-13 12:26:03 +0100
commitce195ba12277ec4286ad0d8ddf7294655987ea9d (patch)
treeb006759d64ae77098b501eeb53bf6ab36ee0d064 /gnu
parent692e05e2933975b6926cab7436a971bb12bd0818 (diff)
downloadguix-patches-ce195ba12277ec4286ad0d8ddf7294655987ea9d.tar
guix-patches-ce195ba12277ec4286ad0d8ddf7294655987ea9d.tar.gz
gnu: Add perl-parallel-forkmanager.
* gnu/packages/perl.scm (perl-parallel-forkmanager): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8f103ec6d7..09278f4251 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2017 Raoul J.P. Bonnal <ilpuccio.febo@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5014,6 +5015,30 @@ show those variables which are in scope at the point of the call. PadWalker
is particularly useful for debugging.")
(license (package-license perl))))
+(define-public perl-parallel-forkmanager
+ (package
+ (name "perl-parallel-forkmanager")
+ (version "1.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/Y/YA/YANICK/Parallel-ForkManager-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0wm4wp6p3ah5z212jl12728z68nmxmfr0f03z1jpvdzffnc2xppi"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-warn" ,perl-test-warn)))
+ (home-page "http://search.cpan.org/dist/Parallel-ForkManager")
+ (synopsis "Simple parallel processing fork manager")
+ (description "@code{Parallel::ForkManager} is intended for use in
+operations that can be done in parallel where the number of
+processes to be forked off should be limited.")
+ (license (package-license perl))))
+
(define-public perl-params-util
(package
(name "perl-params-util")