summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 02:32:22 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 05:41:16 +0100
commitcd4b2e78c59223ddcd0fd8c561b4ff42f87570dc (patch)
treefe171e7e91d74aa1886ad127435dcbb470fc8990 /gnu
parent9b069c15e07145b9c23f1f8e56b3f107ee579c53 (diff)
downloadguix-patches-cd4b2e78c59223ddcd0fd8c561b4ff42f87570dc.tar
guix-patches-cd4b2e78c59223ddcd0fd8c561b4ff42f87570dc.tar.gz
gnu: libxls: Move to (gnu packages statistics).
It has nothing to do with XML. * gnu/packages/xml.scm (libxls): Move from here… * gnu/packages/statistics.scm (libxls): …to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm23
-rw-r--r--gnu/packages/xml.scm21
2 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 04b49def54..e1f48db22d 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016, 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2017 Kyle Meyer <kyle@kyleam.com>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
;;;
@@ -150,6 +150,27 @@ simulation not wholly unlike BUGS. JAGS was written with three aims in mind:
@end enumerate\n")
(license license:gpl2)))
+(define-public libxls
+ (package
+ (name "libxls")
+ (version "1.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/libxls/libxls/releases/download/"
+ "v" version "/libxls-" version ".tar.gz"))
+ (sha256
+ (base32 "00j2lrcvvhclmh3z9vy7myqq1br1jnnqkz2wzgk4a1gbg8c5afn5"))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/libxls/libxls")
+ (synopsis "Read binary (.xls) Excel spreadsheet files")
+ (description
+ "libxls is a C library to read .xls spreadsheet files in the binary OLE
+BIFF8 format as created by Excel 97 and later versions. It cannot write them.
+
+This package also provides @command{xls2csv} to export Excel files to CSV.")
+ (license license:bsd-2)))
+
;; Update this package together with the set of recommended packages: r-boot,
;; r-class, r-cluster, r-codetools, r-foreign, r-kernsmooth, r-lattice,
;; r-mass, r-matrix, r-mgcv, r-nlme, r-nnet, r-rpart, r-spatial, r-survival.
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 9803193bf9..c80dfb1eac 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1254,27 +1254,6 @@ files. It is designed to be fast and to handle large input files.")
(define-public python2-defusedxml
(package-with-python2 python-defusedxml))
-(define-public libxls
- (package
- (name "libxls")
- (version "1.5.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/libxls/libxls/releases/download/"
- "v" version "/libxls-" version ".tar.gz"))
- (sha256
- (base32 "00j2lrcvvhclmh3z9vy7myqq1br1jnnqkz2wzgk4a1gbg8c5afn5"))))
- (build-system gnu-build-system)
- (home-page "https://github.com/libxls/libxls")
- (synopsis "Read binary (.xls) Excel spreadsheet files")
- (description
- "libxls is a C library to read .xls spreadsheet files in the binary OLE
-BIFF8 format as created by Excel 97 and later versions. It cannot write them.
-
-This package also provides @command{xls2csv} to export Excel files to CSV.")
- (license license:bsd-2)))
-
(define-public freexl
(package
(name "freexl")