summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-11-18 17:53:12 -0600
committerEric Bavier <bavier@member.fsf.org>2015-11-19 03:13:19 -0600
commitccd7b3087218d90cc29e11307755fae43aae2904 (patch)
tree061a4b3b9d505642a345a61843ec1e30f02be510 /gnu
parentd2a5210844da10407289683ca2e107fb5769f8f3 (diff)
downloadguix-patches-ccd7b3087218d90cc29e11307755fae43aae2904.tar
guix-patches-ccd7b3087218d90cc29e11307755fae43aae2904.tar.gz
gnu: Add ghc-hostname.
* gnu/packages/haskell.scm (ghc-hostname): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b9387f8d43..e009e0f583 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
+;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -247,6 +248,25 @@
interactive environment for the functional language Haskell.")
(license bsd-3)))
+(define-public ghc-hostname
+ (package
+ (name "ghc-hostname")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/hostname/"
+ "hostname-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0p6gm4328946qxc295zb6vhwhf07l1fma82vd0siylnsnsqxlhwv"))))
+ (build-system haskell-build-system)
+ (home-page "https://hackage.haskell.org/package/hostname")
+ (synopsis "Hostname in Haskell")
+ (description "Network.HostName is a simple package providing a means to
+determine the hostname.")
+ (license bsd-3)))
+
(define-public ghc-prelude-extras
(package
(name "ghc-prelude-extras")