summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-02-13 14:22:18 -0500
committerLudovic Courtès <ludo@gnu.org>2019-02-17 00:04:57 +0100
commitc9ff92b550f4cb27f07ff093d59fc201ffea7e80 (patch)
treef359e6fd2e38489653d257fbea2006a22ee52655 /gnu
parentdef6d6b61685f69421df80cb524ba94da5dadd42 (diff)
downloadguix-patches-c9ff92b550f4cb27f07ff093d59fc201ffea7e80.tar
guix-patches-c9ff92b550f4cb27f07ff093d59fc201ffea7e80.tar.gz
gnu: gdm: Simplify pre-configure phase.
* gnu/packages/gnome.scm (gdm)[arguments]: Simplify the pre-configure phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm34
1 files changed, 15 insertions, 19 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 386203356c..dec567a0e0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5460,25 +5460,21 @@ libxml2.")
"\"/run/current-system/profile/share/wayland")
(("DATADIR \"/gnome")
"\"/run/current-system/profile/share/gnome"))
- (substitute* '("daemon/gdm-session.c")
- (("set_up_session_environment \\(self\\);")
- (string-append
- "set_up_session_environment (self);\n"
- ;; Propagate GDM_X_SERVER environment variable (which is set
- ;; by the GDM service, as it's a function of what X modules
- ;; the user decides to have available) down to worker
- ;; processes.
- "gdm_session_set_environment_variable (self, \"GDM_X_SERVER\",\n"
- " g_getenv (\"GDM_X_SERVER\"));\n"
- ;; Propagate the GDM_CUSTOM_CONF environment variable.
- "gdm_session_set_environment_variable (self, \"GDM_CUSTOM_CONF\",\n"
- " g_getenv (\"GDM_CUSTOM_CONF\"));\n"
- ;; The session bus (which GDM will initialize from the this
- ;; session environment) needs to know where to find the system
- ;; service files.
- "gdm_session_set_environment_variable (self, \"XDG_DATA_DIRS\",\n"
- " \"/run/current-system/profile/share\");\n"
- )))
+ (let ((propagate '("GDM_CUSTOM_CONF"
+ "GDM_X_SERVER"
+ ;; XXX: Remove this once GNOME Shell is
+ ;; a dependency of GDM.
+ "XDG_DATA_DIRS")))
+ (substitute* "daemon/gdm-session.c"
+ (("set_up_session_environment \\(self\\);")
+ (apply string-append
+ "set_up_session_environment (self);\n"
+ (map (lambda (name)
+ (string-append
+ "gdm_session_set_environment_variable "
+ "(self, \"" name "\","
+ "g_getenv (\"" name "\"));\n"))
+ propagate)))))
;; Look for custom GDM conf in /run/current-system.
(substitute* '("common/gdm-settings-desktop-backend.c")
(("GDM_CUSTOM_CONF")