summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-06-18 18:07:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-22 17:55:05 +0200
commitc7a5c3e0bba2ac3d197b219d21527863308b75dd (patch)
treee7915f5c0bf905766d39045b7db83d55990e98ea /gnu
parent7c5d50f431198d08ebc4c83943748132396f666d (diff)
downloadguix-patches-c7a5c3e0bba2ac3d197b219d21527863308b75dd.tar
guix-patches-c7a5c3e0bba2ac3d197b219d21527863308b75dd.tar.gz
gnu: petsc: Link against OpenBLAS rather than LAPACK.
OpenBLAS performs better than LAPACK, the reference implementation. This is also consistent with the choice of BLAS/LAPACK implementations made in most other packages. * gnu/packages/maths.scm (petsc)[inputs]: Replace LAPACK by OPENBLAS. [arguments]: Pass "--with-openblas=1".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 84540d5ffe..dc18536aa7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2417,7 +2417,7 @@ September 2004}")
`(("python" ,python-2)))
(inputs
`(("gfortran" ,gfortran)
- ("lapack" ,lapack)
+ ("openblas" ,openblas)
("superlu" ,superlu)
;; leaving out hdf5 and fftw, as petsc expects them to be built with mpi
;; leaving out opengl, as configuration seems to only be for mac
@@ -2428,6 +2428,7 @@ September 2004}")
#:configure-flags
`("--with-mpi=0"
"--with-openmp=1"
+ "--with-openblas=1"
"--with-superlu=1")
#:make-flags
;; Honor (parallel-job-count) for build. Do not use --with-make-np,